Bug 1311161 - pygit2 fails to import - missing dependency?
pygit2 fails to import - missing dependency?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-pygit2 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Walter
Fedora Extras Quality Assurance
: Reopened
: 1318263 1339790 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 09:25 EST by Barry Scott
Modified: 2016-07-07 05:49 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-pygit2-0.24.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 05:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Scott 2016-02-23 09:25:06 EST
Description of problem:

As non-root python3 import pygit2 fails with:

PermissionError: [Errno 13] Permission denied: '/usr/lib64/python3.4/site-packages/pygit2/__pycache__/pygit2_cffi_6bc76ceexe8494016.c

As root fails with:

>>> import pygit2
/usr/lib64/python3.4/site-packages/pygit2/__pycache__/pygit2_cffi_6bc76ceexe8494016.c:208:18: fatal error: git2.h: No such file or directory
compilation terminated.
Traceback (most recent call last):
  File "/usr/lib64/python3.4/distutils/unixccompiler.py", line 126, in _compile
    extra_postargs)
  File "/usr/lib64/python3.4/distutils/ccompiler.py", line 909, in spawn
    spawn(cmd, dry_run=self.dry_run)
  File "/usr/lib64/python3.4/distutils/spawn.py", line 36, in spawn
    _spawn_posix(cmd, search_path, dry_run=dry_run)
  File "/usr/lib64/python3.4/distutils/spawn.py", line 162, in _spawn_posix
    % (cmd, exit_status))
distutils.errors.DistutilsExecError: command 'gcc' failed with exit status 1


Version-Release number of selected component (if applicable):

python3-pygit2-0.23.0-0.1.fc23.x86_64
libgit2-0.23.4-1.fc23.x86_64

How reproducible:

Make sure that libgit2-devel is not installed before installing python3-pygit2.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

I appears that there is a missing dependency on libgit2-devel that is not automatically installed when pygit2 is installed.
Comment 1 Barry Scott 2016-02-23 09:26:16 EST
The component is wrong. I could not find python3-pygit2 as a choice.
Comment 2 Petr Viktorin 2016-02-23 09:50:15 EST
python3-pygit2 is part of the python-pygit2 source package.

Let me know if you need any help related to Python3.
Comment 3 Fedora Admin XMLRPC Client 2016-02-26 12:38:03 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2016-02-26 13:05:30 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Igor Gnatenko 2016-03-20 10:24:51 EDT
*** Bug 1318263 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2016-03-29 19:04:32 EDT
rubygem-rugged-0.24.0-1.fc24 julia-0.4.5-2.fc24 gnome-builder-3.20.0-1.fc24 gitg-3.20.0-1.fc24 subsurface-4.4.2-5.fc24 python-pygit2-0.24.0-1.fc24 libgit2-glib-0.24.0-2.fc24 libgit2-0.24.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fadc1e6504
Comment 7 Fedora Update System 2016-03-30 18:26:27 EDT
gitg-3.20.0-1.fc24, gnome-builder-3.20.0-1.fc24, julia-0.4.5-2.fc24, kate-15.12.3-2.fc24, kf5-ktexteditor-5.20.0-3.fc24, libgit2-0.24.0-1.fc24, libgit2-glib-0.24.0-2.fc24, python-pygit2-0.24.0-1.fc24, rubygem-rugged-0.24.0-1.fc24, subsurface-4.4.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fadc1e6504
Comment 8 Miro Hrončok 2016-03-30 18:59:14 EDT
F23 please.
Comment 9 Fedora Update System 2016-03-31 16:29:30 EDT
gitg-3.20.0-1.fc24, gnome-builder-3.20.0-1.fc24, julia-0.4.5-2.fc24, kate-15.12.3-2.fc24, kf5-ktexteditor-5.20.0-3.fc24, libgit2-0.24.0-1.fc24, libgit2-glib-0.24.0-2.fc24, python-pygit2-0.24.0-1.fc24, rubygem-rugged-0.24.0-1.fc24, subsurface-4.4.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Miro Hrončok 2016-04-01 07:30:06 EDT
This was reported as a bug on F23 and closed with build on F24. Reopening.
Comment 11 Fedora Admin XMLRPC Client 2016-04-04 16:31:51 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora Admin XMLRPC Client 2016-04-04 16:42:46 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Igor Gnatenko 2016-05-27 05:06:04 EDT
*** Bug 1339790 has been marked as a duplicate of this bug. ***
Comment 14 Igor Gnatenko 2016-07-07 05:49:10 EDT
Sorry, I can't do anything here. It requires updating to 0.24.x, but it will require rebuild/patch/update of other components.

Note You need to log in before you can comment on or make changes to this bug.