Bug 1311170 - Allow remotely executed commands to deliver its exit code during reboot
Allow remotely executed commands to deliver its exit code during reboot
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On: 1352264
Blocks: 1298574 1313485
  Show dependency treegraph
 
Reported: 2016-02-23 09:42 EST by Tomáš Kašpárek
Modified: 2016-07-03 01:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-03 01:17:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Kašpárek 2016-02-23 09:42:56 EST
Description of problem:
We should be able to deliver exit code of remotely executed commands when restart comes during remote command execution.

Version-Release number of selected component (if applicable):
rhn-client-tools-2.0.2-6.el7

How reproducible:
100%
https://bugzilla.redhat.com/show_bug.cgi?id=1260527

Steps to Reproduce:
1. setup osad on client
2. execute remote command with remoot/shutdown -r now/init 6

Actual results:
reboot loop because of not delivering exit code of remote command

Expected results:
exit code of remote command should be delivered to Satellite, client reboot should follow AFTER that

Additional info:
we need to mask SIGTERM during remote command execution, leftover processes are killed by SIGKILL after 90 seconds, but we should be able to do it faster
Comment 1 Tomáš Kašpárek 2016-07-03 01:17:50 EDT
We can't fix this due to current systemd behavior. Something needs to be done with BZ#1352264 first...

Note You need to log in before you can comment on or make changes to this bug.