Bug 1311180 - rabbitmq-cluster agent needs to forget stopped cluster nodes
rabbitmq-cluster agent needs to forget stopped cluster nodes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Oyvind Albrigtsen
Leonid Natapov
: ZStream
Depends On: 1247303
Blocks: 1350073 1357991 1387985
  Show dependency treegraph
 
Reported: 2016-02-23 09:48 EST by Jan Kurik
Modified: 2016-11-01 14:14 EDT (History)
16 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-54.el7_2.7
Doc Type: Bug Fix
Doc Text:
Cause: rabbitmq doesnt forget members quick enough Consequence: After fencing, a rabbitmq-cluster resource instance may not be able to rejoin the rabbitmq cluster. Fix: Use "rabbitmqctl forget_cluster_node <node>" when a node is fenced Result: Node is removed from cluster and can join again
Story Points: ---
Clone Of: 1247303
Environment:
Last Closed: 2016-03-31 18:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-02-23 09:48:54 EST
This bug has been copied from bug #1247303 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 9 Leonid Natapov 2016-03-20 09:09:37 EDT
verified resource-agents-3.9.5-54.el7

[root@overcloud-controller-0 heat-admin]# pcs resource show rabbitmq
 Resource: rabbitmq (class=ocf provider=heartbeat type=rabbitmq-cluster)
  Attributes: set_policy="ha-all ^(?!amq\.).* {"ha-mode":"all"}" 
  Meta Attrs: notify=true 
  Operations: start interval=0s timeout=100 (rabbitmq-start-interval-0s)
              stop interval=0s timeout=90 (rabbitmq-stop-interval-0s)
              monitor interval=10 timeout=40 (rabbitmq-monitor-interval-10)
Comment 11 errata-xmlrpc 2016-03-31 18:08:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0556.html
Comment 12 Peter Lemenkov 2016-06-24 09:33:27 EDT
If someone still sees this issue, then please test this package:

resource-agents-3.9.5-76.el7

Note You need to log in before you can comment on or make changes to this bug.