Bug 1311300 - redis has client/server timeouts set to 0
redis has client/server timeouts set to 0
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity high
: ga
: 8.0 (Liberty)
Assigned To: Jason Guiditta
Leonid Natapov
: Triaged
Depends On: 1257693
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 15:49 EST by Jason Guiditta
Modified: 2016-04-07 17:30 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.13-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257693
Environment:
Last Closed: 2016-04-07 17:30:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 284775 None None None 2016-02-25 10:50 EST
OpenStack gerrit 287974 None None None 2016-03-03 11:54 EST

  None (edit)
Description Jason Guiditta 2016-02-23 15:49:38 EST
+++ This bug was initially created as a clone of Bug #1257693 +++

This BZ is to cover the redis half of this fix.

Currently, rhel-osp-director configures the mysql proxy in haproxy.cfg to have client and server timeout set to 0. This is incorrect. Doing this will result in the following warning:

[WARNING] 238/115010 (13878) : config : missing timeouts for proxy 'mysql'.
| While not properly invalid, you will certainly encounter various problems
| with such a configuration. To fix this, please ensure that all following
| timeouts are set to a non-zero value: 'client', 'connect', 'server'.
[WARNING] 238/115010 (13878) : config : missing timeouts for proxy 'redis'.
| While not properly invalid, you will certainly encounter various problems
| with such a configuration. To fix this, please ensure that all following
| timeouts are set to a non-zero value: 'client', 'connect', 'server'.

The mysql timeouts should be >60m. I am not sure that the appropriate timeouts for redis should be.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-08-27 12:56:53 EDT ---

Since this issue was entered in bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-08-27 12:56:53 EDT ---

The Target Release has been set to match the release flag.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-08-28 12:14:22 EDT ---

This bug has been given a pm_ack+ since it is not a blocker, has been triaged, and does not need pm review.

--- Additional comment from Emilien Macchi on 2015-09-14 13:03:17 EDT ---

Patch sent upstream for MySQL: https://review.openstack.org/223223

--- Additional comment from Mike Burns on 2015-10-19 11:42:31 EDT ---

Emilien, what about redis?  Is that going to be fixed in this bug too? or should we split the bug?

--- Additional comment from Jason Guiditta on 2016-02-23 15:47:07 EST ---

The upstream patch for mysql (in puppet-tripleo) is merged, I am going to clone this to cover the redis half, so mysql can move forward
Comment 1 Jason Guiditta 2016-02-25 10:49:29 EST
Submitted review for master: https://review.openstack.org/#/c/284775/ . Once this has been merged, I will update this BZ with the cherry-pick review
Comment 2 Jason Guiditta 2016-03-04 15:43:37 EST
Merged upstream
Comment 5 Leonid Natapov 2016-03-23 08:41:07 EDT
openstack-puppet-modules-7.0.15-1.el7ost

from haproxy.cfg

No timeout dor redis.

listen redis
  bind 172.17.0.10:6379 transparent
  balance first
  option tcp-check
  tcp-check send info\ replication\r\n
  tcp-check expect string role:master
Comment 6 errata-xmlrpc 2016-04-07 17:30:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.