Bug 1311305 - On KDE, some actions (such as mount external drives via Dolphin) are forbidden
On KDE, some actions (such as mount external drives via Dolphin) are forbidden
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: polkit-kde (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 16:26 EST by Giulio 'juliuxpigface'
Modified: 2016-03-08 15:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 15:06:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error while mounting external drives (965.70 KB, image/png)
2016-02-23 16:26 EST, Giulio 'juliuxpigface'
no flags Details
Error while checking updates with Apper (774.09 KB, image/png)
2016-02-23 16:27 EST, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2016-02-23 16:26:13 EST
Created attachment 1129924 [details]
Error while mounting external drives

Description of problem:
I found 3 issue while testing the 20160223 compose of Fedora Rawhide (KDE):

1) I'm not able to mount external drives. I receive the message "Not authorized to perform operation".
2) I'm not able to check the updates via Apper. I receive the message "Failed to obtain the authentication"
3) I don't receive messages, but clicking on the "System" button on ABRT - in order to read about system's crashes - does nothing.

I was suspecting that these issue are all caused by the lack of a polkit agent. But, according to "ps aux", "polkitd" and "polkit-authentication-agent-1" seems to be up and running.

However, no popup window has pinged me for passwords nor authentication. I'm pretty sure all of the above issues share a common cause, but I'll file new bugs if needed.

Version-Release number of selected component (if applicable):
polkit-kde-5.5.4-2.fc24.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Launch a Plasma session.
2. Try to mount an external drive.
3. Try to Check updates with Apper.
4. Try to read ABRT's system reports.


Actual results:
Steps 2, 3 and 4 fail because there isn't an easy way to input the user's credentials.


Expected results:
Users should be able to mount external drives, updates their system with Apper and use every feature of ABRT. When needed, a modal window should pop up in order to provide an obvious way to provide passwords nor login names.


Additional info:
1. The user is not in the "wheel" group.
2. I'm testing with qemu-kvm and I can download and install a more recent compose (or update the system via dnf), if needed.
3. I'm attaching two screenshot in order to illustrate the issues.
Comment 1 Giulio 'juliuxpigface' 2016-02-23 16:27 EST
Created attachment 1129925 [details]
Error while checking updates with Apper
Comment 2 Giulio 'juliuxpigface' 2016-02-25 16:50:35 EST
(In reply to Giulio 'juliuxpigface' from comment #0)
> 2. I'm testing with qemu-kvm and I can download and install a more recent
> compose (or update the system via dnf), if needed.

Tonight I've applied the pending updates, including the brand new"kf5-plasma-5.19.0-2.fc24.x86_64". I can confirm the issue is still present.
Comment 3 Giulio 'juliuxpigface' 2016-03-08 15:06:06 EST
I've tested this with an up to date F24 qemu-kvm guest.

I'm closing this bug report since I can't reproduce the issues anymore.

Note You need to log in before you can comment on or make changes to this bug.