Bug 1311307 - libgflags-devel doesn't ship pkg-config *.pc files
libgflags-devel doesn't ship pkg-config *.pc files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gflags (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 16:41 EST by Evan Klitzke
Modified: 2016-02-27 12:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-27 12:43:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch gflags.spec to include .pc files (343 bytes, text/plain)
2016-02-23 18:13 EST, Evan Klitzke
no flags Details

  None (edit)
Description Evan Klitzke 2016-02-23 16:41:30 EST
The gflags-devel package (on x86-64) should include at least the following file:

    /usr/lib64/pkgconfig/libgflags.pc

What's interesting is that glog-devel correctly installs libglog.pc so I'm sure it's a simple matter of looking at the SRPMS to see what's different between glog and gflags.

What's also interesting is that both of these packages (glog and gflags) can be built without threading support. On a Debian Jessie system, if you install libgflags-dev you get all of the following files:

    /usr/lib/x86_64-linux-gnu/libgflags.a
    /usr/lib/x86_64-linux-gnu/pkgconfig
    /usr/lib/x86_64-linux-gnu/pkgconfig/libgflags_nothreads.pc
    /usr/lib/x86_64-linux-gnu/pkgconfig/libgflags.pc
    /usr/lib/x86_64-linux-gnu/libgflags.so
    /usr/lib/x86_64-linux-gnu/libgflags_nothreads.so

On a Fedora 23 system if you install libgflags-devel you do get the .so built both ways, but you don't get a .a file nor do you get the .pc file, i.e. you'll see the following installed by gflags-devel:

    /usr/lib64/libgflags.so
    /usr/lib64/libgflags_nothreads.so
Comment 1 Evan Klitzke 2016-02-23 18:13 EST
Created attachment 1129954 [details]
patch gflags.spec to include .pc files

should work like:

  test -f gflags.spec && patch -p0<gflags.patch
Comment 2 Evan Klitzke 2016-02-27 12:43:32 EST
This doesn't work because upstream seems to have broken support for creating pkgconfig files.

I do, however, have a new SPEC and patches for gflags-2.1.2 that I will post in a new bug.

Note You need to log in before you can comment on or make changes to this bug.