Bug 131131 - New tutorial: updates tutorial
New tutorial: updates tutorial
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
:
Depends On:
Blocks: fedora-docs-ready
  Show dependency treegraph
 
Reported: 2004-08-27 16:15 EDT by Tammy Fox
Modified: 2009-07-07 00:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-12 17:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New candidate 0.1.3, revisions by PWF (13.02 KB, text/plain)
2004-08-27 18:07 EDT, Paul W. Frields
no flags Details

  None (edit)
Description Tammy Fox 2004-08-27 16:15:44 EDT
Dave Pawson submitted a tutorial on how to use Yum to update Fedora
Core. I have edited it and am awaiting his approval on edits before
posting to fedora.redhat.com/docs/.
Comment 1 Paul W. Frields 2004-08-27 16:59:24 EDT
I would like to suggest that we rename this article the
yum-update-tutorial, since it doesn't cover using up2date (with yum or
otherwise). My personal feeling is that up2date should be the
preferred tool, since it has text and GUI interfaces, and provides a
helpful and user-friendly interface regardless of what back end engine
the user prefers. I think there should be either a more global
update-tutorial, or at least a separate up2date-update-tutorial.

The tutorial, as is, has a lot of grammatical and syntactical errors,
and seems to fly in the face of some standard style guidelines. (This
isn't intended as a slight -- the article is no worse than a lot of
others I've seen on unofficial Fedora sites, and in fact better than
many.) In the interest of getting it on the Web, given the current
paucity of docs, we shouldn't make style edits a barrier. But I will
submit a patch to fix these problems, as I see them, that Tammy and
Dave can review.

I'm working on it now and hope to have something by late tonight
(US/Eastern, Friday).
Comment 2 Paul W. Frields 2004-08-27 17:00:31 EDT
Umm, in short, what I should have added there was, "I volunteer to do
further edits, so as not to make anyone else responsible for my
pickiness."
Comment 3 Tammy Fox 2004-08-27 17:43:36 EDT
Sure. While reading it, I did notice that the writing style is a
little looser than I would prefer, but I didn't want to edit it too
heavily to sound like I wrote it. Since this is part of a community
project, I am trying to let people's personality and writing styles
shine through within reason. Paul, please submit your patch and Dave
can say whether he is OK with them or not.

I also agree that we also need to have docs on using up2date as well.
I would prefer to just add that to this doc as another section. It
makes the tutorial task-based instead of application-specific. If
someone knows they need updates but doesn't know the name of the
application to get updates, it is easier for him to find the tutorial
if it has a generic title like "Getting Updates." 

After you make your edits, I'll go back through and add a section for
up2date and see if anyone on the list wants to tackle it. I did write
a really short version of using up2date with FC for Wide Open
Magazine, so I'll probably start the section with that and see if
anyone else wants to expand it.

At least we have this very important tutorial started!
Comment 4 Paul W. Frields 2004-08-27 18:07:23 EDT
Created attachment 103191 [details]
New candidate 0.1.3, revisions by PWF

I didn't read carefully enough. There is a short section on up2date in this
tutorial. It might be a nice idea to expand it later, to include the rhn-applet
and/or use of the up2date client software.

This attachment has been run through Emacs/psgml, which is what I use. When I
made my first round of edits, I was careful to change as little in the way of
indentation and spacing as possible. The patch still ended up being about 70%
the size of the original. I decided therefore to simply re-fill the whole thing
with psgml in xml-mode. Hopefully it shouldn't cause anyone real heartburn.

Dave, if you could check out this version and make sure it still flows. I tried
to keep as much as possible while making a stab at agreement with at least
those style guidelines I think will probably be universally acceptable. Thanks
for authoring this!
Comment 5 Tammy Fox 2004-08-30 10:17:45 EDT
Paul, I was about to apply your patch and realized that I had
forgotten to commit my last round of edits like I thought I did when I
last posted to this bug. I'll apply yours and then try to see if I can
figure out what edits I made from that. That would explain why there
were so many indention and grammar errors after I handed it off -- I
forgot to commit my fixes. Oops!
Comment 6 Tammy Fox 2004-08-30 22:09:41 EDT
The patch looks fine. I have committed Paul's changes and changed this
bug to block #129722, indicating that it is ready to be posted to the
website.
Comment 7 Tammy Fox 2004-09-12 17:11:35 EDT
This tutorial has been posted to fedora.redhat.com.
Comment 8 eric@christensenplace.us 2009-07-07 00:08:36 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.