Bug 1311349 - rpmspec behaves strangely
rpmspec behaves strangely
Status: CLOSED DUPLICATE of bug 1293687
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-02-23 19:58 EST by Zbigniew Jędrzejewski-Szmek
Modified: 2016-02-24 03:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-24 03:24:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2016-02-23 19:58:56 EST
Description of problem:
I was trying to use rpmspec to extract some information from a spec file. rpmspec does two strange things:
1. It looks for files in ~/rpmbuild/SOURCES/ even though it doesn't need them for anything. I guess it's trying to be helpful but it's just annoying.

2. It prints things twice.

Version-Release number of selected component (if applicable):

Steps to reproduce:
$ fedpkg clone elasticsearch && cd elasticsearch
$ rpmspec -q --queryformat=x%{version}x elasticsearch.spec

Actual results:
error: File /home/zbyszek/rpmbuild/SOURCES/elasticsearch-1.3.2-remove-sigar-service.patch: No such file or directory
error: File /home/zbyszek/rpmbuild/SOURCES/unbundleBase64.patch: No such file or directory
error: File /home/zbyszek/rpmbuild/SOURCES/localhostByDefault.patch: No such file or directory
error: File /home/zbyszek/rpmbuild/SOURCES/netty-version.patch: No such file or directory
Expected results:
Comment 1 Ľuboš Kardoš 2016-02-24 03:24:47 EST
1. This has been already reported and fixed in rawhide (bug 1293687).

2. That is correct because your spec file contains two packages:
$ rpmspec -q elasticsearch.spec 

So the version of each package from spec file is showed.

*** This bug has been marked as a duplicate of bug 1293687 ***

Note You need to log in before you can comment on or make changes to this bug.