Bug 1311362 - [AFR]: "volume heal info" command is failing during in-service upgrade to latest.
[AFR]: "volume heal info" command is failing during in-service upgrade to lat...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Anuradha
Byreddy
: ZStream
Depends On:
Blocks: 1268895 1299184 1332798 1333239 1333243
  Show dependency treegraph
 
Reported: 2016-02-23 23:07 EST by Byreddy
Modified: 2016-09-19 22:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-4
Doc Type: Bug Fix
Doc Text:
The heal info command expects bricks to have the .indices/dirty directory. However, older nodes do not have this directory. After in-service upgrades on a node, the heal info command failed when run from newer nodes due to missing .indices/dirty directory on old nodes. The missing directory is now ignored on older nodes and heal info command after in-service upgrades does not fail in this situation.
Story Points: ---
Clone Of:
: 1332798 (view as bug list)
Environment:
Last Closed: 2016-06-23 01:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2016-02-23 23:07:42 EST
Description of problem:
=======================
Volume heal info command is failing  duing in-service update from 3.1.1 to 3.1.2 with IO running, command is failing with error message "Failed to process entries completely."


Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.5-19


How reproducible:
=================
Every time

Steps to Reproduce:
===================
1.Have two node (node-1 and node-2)  3.1.1 cluster with distribute-replica volume (2 *2)
2. FUSE mount the volume  and start linux kernel  untar in the mount point.
3. Update node-1 as per the update steps to 3.1.2
4. Start manual volume heal on node-1 // volume heal <volname>
5. Check the heal info on node-1 // volume heal <volname> info   ==> will through error message  "Failed to process entries completely. "



Actual results:
===============
volume heal info command is failing with error message  "Failed to process entries completely. "

Expected results:
=================
Command should not fail

Additional info:
Comment 8 Byreddy 2016-05-12 05:02:13 EDT
Verified this bug using the build - "glusterfs-3.7.9-4"

Done the update from 3.1.1 to latest 3.1.3 build and found that "heal info" command is working good.

Moving to verified state.
Comment 10 Anuradha 2016-06-03 03:01:22 EDT
Laura,

I've made some changes. Please correct grammatical mistakes, if any.
Comment 13 errata-xmlrpc 2016-06-23 01:09:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.