Bug 1311410 - Failed to deploy registry pod if the volume name is not 'registry' in inventory
Failed to deploy registry pod if the volume name is not 'registry' in inventory
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 03:05 EST by Anping Li
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:38:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1065 normal SHIPPED_LIVE Red Hat OpenShift Enterprise atomic-openshift-utils bug fix update 2016-05-12 16:32:56 EDT

  None (edit)
Description Anping Li 2016-02-24 03:05:58 EST
Description of problem:
The installer creates pv and pvc according to the volume name. If the volume name is not "registry",the docker-registry pod can't be started.

Version-Release number of selected component (if applicable):
openshift-ansible/master

How reproducible:
always

Steps to Reproduce:

1. Enable NFS on inventory file
2. set volume name to a customlized name.  
   For example: openshift_hosted_registry_storage_volume_name=registry123
3. ansible-playbook -i config/aepnfs31 /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml
4. check the pv, pvc and dc 

Actual results:
#oc get pv
NAME  LABELS    CAPACITY   ACCESSMODES   STATUS CLAIM   REASON    AGE
registry123-volume  <none>  5Gi RWX Bound default/registry123-claim  11m

# oc get pvc
NAME  LABELS    STATUS    VOLUME  CAPACITY   ACCESSMODES   AGE
registry123-claim <none> Bound registry123-volume 5Gi RWX  11m

# oc get dc docker-registry -o yaml |grep claim
   claimName: registry-claim

Expected results:

The pv/pvc name is the fix value registry. or the dc are updated according to the volume name.

Additional info:
Comment 1 Andrew Butcher 2016-02-24 11:23:32 EST
Proposed fix: https://github.com/openshift/openshift-ansible/pull/1486
Comment 2 Anping Li 2016-02-24 21:32:42 EST
The docker-registry can be started now. so move to verified.

# oc get dc docker-registry -o json |grep claim
    "claimName": "registry124-claim"
Comment 4 errata-xmlrpc 2016-05-12 12:38:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.