Bug 1311417 - python-nova requires oslo.serialization
python-nova requires oslo.serialization
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
x86_64 Linux
high Severity high
: z5
: 6.0 (Juno)
Assigned To: Eoghan Glynn
Prasanth Anbalagan
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 03:25 EST by Simon Reber
Modified: 2018-02-08 06:15 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-68.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-01 08:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Reber 2016-02-24 03:25:37 EST
Description of problem:

When updating a system with the latest package updates, the package "python-oslo-serialization" is not pulled in correctly, leaving some OpenStack components unable to run.

By manually installing the "python-oslo-serialization" package, the daemons are starting correctly.

Version-Release number of selected component (if applicable):
python-nova-2014.2.3-35.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. update to python-nova-2014.2.3-35.el7ost.noarch

Actual results:

Problems because of missing dependency (python-oslo-serialization)

Expected results:

Update should proceed and complete without failure and missing dependecy


Additional info:

Please add python-oslo-serialization to openstack-nova.spec as "Require"
This is a follow-up task from https://bugzilla.redhat.com/show_bug.cgi?id=1270682 as this only covers python-keystonemiddleware but we have other components that are affected as well
Comment 6 Prasanth Anbalagan 2016-05-17 21:13:16 EDT
Verified as follows, 

No errors observed updating to 2014.2.3-71.el7ost.

[root@servera ~]# yum update python-nova
Loaded plugins: langpacks, priorities, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package python-nova.noarch 0:2014.2.3-67.el7ost will be updated
---> Package python-nova.noarch 0:2014.2.3-71.el7ost will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================================
 Package                      Arch                    Version                                Repository                           Size
=======================================================================================================================================
Updating:
 python-nova                  noarch                  2014.2.3-71.el7ost                     rhelosp-6.0-puddle                  3.0 M

Transaction Summary
=======================================================================================================================================
Upgrade  1 Package

Total download size: 3.0 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
python-nova-2014.2.3-71.el7ost.noarch.rpm                                                                       | 3.0 MB  00:00:02     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Updating   : python-nova-2014.2.3-71.el7ost.noarch                                                                               1/2 
  Cleanup    : python-nova-2014.2.3-67.el7ost.noarch                                                                               2/2 
  Verifying  : python-nova-2014.2.3-71.el7ost.noarch                                                                               1/2 
  Verifying  : python-nova-2014.2.3-67.el7ost.noarch                                                                               2/2 

Updated:
  python-nova.noarch 0:2014.2.3-71.el7ost                                                                                              

Complete!
[root@servera ~]#
Comment 8 errata-xmlrpc 2016-06-01 08:29:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1194

Note You need to log in before you can comment on or make changes to this bug.