Bug 1311459 - [networking_public_99]Minus number could be set in router RELOAD_INTERVAL
Summary: [networking_public_99]Minus number could be set in router RELOAD_INTERVAL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Eric Paris
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-24 10:01 UTC by Yan Du
Modified: 2017-03-08 18:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:35:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Yan Du 2016-02-24 10:01:34 UTC
Description of problem:
minus number could be set in router RELOAD_INTERVAL


Version-Release number of selected component (if applicable):
oc v3.1.1.904
kubernetes v1.2.0-alpha.7-703-gbc4550d


How reproducible:
Always

Steps to Reproduce:
1. Create router in your env
2. Edit router dc to set a reload time to a minus value for router
        - name: RELOAD_INTERVAL
          value: -100s
3. Check the router log (set loglevel=5 for router)



Actual results:
Got "Template router will coalesce reloads within -100 seconds of each other" info from the log
[root@ip-172-18-0-36 ~]# oc logs router-9-qol1l
I0216 09:40:36.848332       1 router.go:116] Creating a new template router, writing to /var/lib/containers/router
I0216 09:40:36.853388       1 router.go:118] Router will use default/router service to identify peers
I0216 09:40:36.853421       1 router.go:158] Template router will coalesce reloads within -100 seconds of each other
I0216 09:40:36.853427       1 router.go:163] Reading persisted state
I0216 09:40:36.854875       1 router.go:167] Committing state
I0216 09:40:36.855813       1 router.go:224] Writing the router state
I0216 09:40:36.856570       1 router.go:229] Writing the router config
I0216 09:40:36.857066       1 router.go:234] Reloading the router
I0216 09:40:36.997549       1 router.go:161] Router is including routes in all namespaces
I0216 09:40:36.997632       1 controller.go:40] Running router controller
I0216 09:40:36.997644       1 reaper.go:17] Launching reaper


Expected results:
Minus number could not be set for router RELOAD_INTERVAL

Comment 1 Eric Paris 2016-02-24 14:11:11 UTC
https://github.com/openshift/origin/pull/7589

Comment 2 Ram Ranganathan 2016-03-05 22:25:50 UTC
Fixed with https://github.com/openshift/origin/pull/7703 - completing the paperwork.

Comment 3 Yan Du 2016-03-08 08:18:33 UTC
Test on latest origin code, bug have been fixed

router will be deployed failed when set minus number in router RELOAD_INTERVAL

[root@ip-172-18-13-133 ~]# oc logs router-5-xnbd8
F0308 08:15:40.370781       1 helpers.go:107] error: invalid reload interval: -100 - must be a positive duration

QE will verify the bug once the PR merge to OSE

Comment 4 Yan Du 2016-03-22 09:25:22 UTC
Test on latest ose env, issue have been fixed on ose.

oc v3.2.0.6
kubernetes v1.2.0-36-g4a3f9c5

# oc logs router-4-qmcx7
F0322 05:22:10.826550       1 helpers.go:107] error: invalid reload interval: -90 - must be a positive duration

# oc logs router-5-qcy15
W0322 05:24:35.872227       1 template.go:66] Invalid RELOAD_INTERVAL "dbdn", using default value 5 ...


Could you please move the bug to ON_QA, then I could verify it. Thanks!

Comment 5 Troy Dawson 2016-09-01 15:50:32 UTC
This has been merged into ose and is in OSE v3.3.0.28 or newer.

Comment 7 Yan Du 2016-09-02 08:36:54 UTC
Issue have been fixed on

oc v3.3.0.28
kubernetes v1.3.0+507d3a7

Comment 9 errata-xmlrpc 2016-09-27 09:35:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.