Bug 1311495 - Add support for URL parameters in actions
Add support for URL parameters in actions
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-sdk-python
Classification: oVirt
Component: Core (Show other bugs)
3.6.3.0
Unspecified Unspecified
medium Severity low (vote)
: ovirt-3.6.5
: 3.6.5.0
Assigned To: Juan Hernández
movciari
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 06:15 EST by Juan Hernández
Modified: 2016-04-21 10:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: ovirt-engine-sdk-python-3.6.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:37:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
juan.hernandez: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53961 master ABANDONED sdk: Support URL parameters in actions 2016-03-03 14:35 EST
oVirt gerrit 53962 sdk_3.6 MERGED sdk: Support URL parameters in actions 2016-03-28 06:58 EDT

  None (edit)
Description Juan Hernández 2016-02-24 06:15:40 EST
Currently the Python SDK doesn't support the URL parameters available in actions. For example, the action that deactivates a host has a "stop_gluster_service" parameter, but it is impossible to use it with the Python SDK because the signature of the corresponding method is like this:

  def deactivate(
      self,
      action=params.Action(),
      correlation_id=None
  )

To support these parameters the signature should be like this:

  def deactivate(
      self,
      action=params.Action(),
      correlation_id=None,
      stop_gluster_service=None
  )

Note You need to log in before you can comment on or make changes to this bug.