Bug 1311512 - list-harddrives shows software RAID devices
list-harddrives shows software RAID devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On:
Blocks: 1256306
  Show dependency treegraph
 
Reported: 2016-02-24 06:43 EST by Jan Stodola
Modified: 2017-02-09 03:56 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.64-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:22:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (4.32 KB, text/plain)
2016-02-24 06:45 EST, Jan Stodola
no flags Details
program.log (22.27 KB, text/plain)
2016-02-24 06:45 EST, Jan Stodola
no flags Details
storage.log (59.58 KB, text/plain)
2016-02-24 06:45 EST, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2016-02-24 06:43:55 EST
Description of problem:
When running list-harddrives in %pre section of a kickstart file on a system with a software RAID, this RAID device is shown in the list of available hard drives.

Version-Release number of selected component (if applicable):
RHEL-7.2 GA
anaconda-21.48.22.56-1.el7

How reproducible:
always

Steps to Reproduce:
1. have a system with a software RAID
2. run a kickstart installation containing
%pre
list-harddrives > /hdds
%end

3. check the content of /hdds during the installation

Actual results:
md127 5120.0
vda 10240.0
vdb 10240.0

Expected results:
* Software RAID devices are not listed
vda 10240.0
vdb 10240.0
Comment 1 Jan Stodola 2016-02-24 06:45 EST
Created attachment 1130185 [details]
anaconda.log
Comment 2 Jan Stodola 2016-02-24 06:45 EST
Created attachment 1130186 [details]
program.log
Comment 3 Jan Stodola 2016-02-24 06:45 EST
Created attachment 1130187 [details]
storage.log
Comment 5 Martin Kolman 2016-04-08 12:24:23 EDT
The script no longer returns software RAID devices + a documentation file has been added to docs/list-harddrives.rst describing how the list-harddrives script works.
Comment 7 Peter Kotvan 2016-07-19 05:26:56 EDT
Verified on RHEL-7.3-20160707.2 with RHEL-7.3-20160707.2.
Comment 8 Peter Kotvan 2016-07-19 05:27:51 EDT
With anaconda-21.48.22.79-1.el7 actually.
Comment 10 errata-xmlrpc 2016-11-03 19:22:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.