Bug 1311514 - Serial port collisions can occur when live migrating instances
Serial port collisions can occur when live migrating instances
Status: CLOSED DUPLICATE of bug 1313171
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
x86_64 Linux
medium Severity medium
: ---
: 9.0 (Mitaka)
Assigned To: Lee Yarwood
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 06:46 EST by Lee Yarwood
Modified: 2016-05-10 10:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 10:22:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2016-02-24 06:46:17 EST
Description of problem:

Serial port collisions can occur when live migrating instances.

The live migration of instances with serial ports attached is supported with Liberty. BZ#1310140 also enables these live migrations for RHEL OSP 7.0.z.

Version-Release number of selected component (if applicable):
12.0.1
2015.1.3

How reproducible:
Always.

Steps to Reproduce:
1. Live migrate an instance to a destination host where an instance is already using a given serial console port.

Actual results:
Live migration fails as these ports collide on the destination host.

Expected results:
A new serial console port is selected on the destination and used by the migrating instance.

Additional info:

Current topic branch looking to address this in M :
https://review.openstack.org/#/q/topic:refactoring-libvirt
Comment 2 Lee Yarwood 2016-05-10 10:22:34 EDT

*** This bug has been marked as a duplicate of bug 1313171 ***

Note You need to log in before you can comment on or make changes to this bug.