Bug 1311536 - python-django-helpdesk: Provide a Python 3 subpackage
python-django-helpdesk: Provide a Python 3 subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-django-helpdesk (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luis Bazan
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2016-02-24 07:25 EST by Tomas Orsava
Modified: 2016-11-18 10:13 EST (History)
5 users (show)

See Also:
Fixed In Version: python-django-helpdesk-0.1.18-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-18 10:13:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to patched 0.1.17 version including Python 3 subpackage (6.60 KB, patch)
2016-08-22 13:19 EDT, Jan Beran
no flags Details | Diff
Patch: syntax correction for Python 3.4 and 3.5 (699 bytes, patch)
2016-08-23 14:35 EDT, Jan Beran
no flags Details | Diff
Update to patched 0.1.17 version including Python 3 subpackage (6.58 KB, patch)
2016-09-08 08:40 EDT, Jan Beran
no flags Details | Diff
Update to patched 0.1.17 version including Python 3 subpackage (6.57 KB, patch)
2016-09-08 10:12 EDT, Jan Beran
no flags Details | Diff
Update to patched 0.1.17 version including Python 3 subpackage (6.56 KB, patch)
2016-09-09 08:14 EDT, Jan Beran
no flags Details | Diff
Update to new 0.1.18 version including Python 3 subpackage (6.38 KB, patch)
2016-11-09 02:48 EST, Jan Beran
no flags Details | Diff

  None (edit)
Description Tomas Orsava 2016-02-24 07:25:37 EST
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 1 Petr Viktorin 2016-04-19 09:29:47 EDT
Luis, do you need any help with adding Python 3 support?
Comment 2 Jan Kurik 2016-07-26 00:06:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 3 Jan Beran 2016-08-22 13:19 EDT
Created attachment 1193023 [details]
Update to patched 0.1.17 version including Python 3 subpackage

I prepared a spec file update that includes
- update to patched version 0.1.17
- source update
- modernized specfile with Python 3 packaging
Comment 4 Jan Beran 2016-08-22 13:23:40 EDT
The attached specfile contains also a correction related to this bug that occurs in the original spec file:

$ rpmlint python-django-helpdesk.spec
python-django-helpdesk.spec: E: specfile-error warning: bogus date in %changelog: Tue Oct 22 2014 Luis Bazan <lbazan@fedoraproject.org> - 0.1.12-4
0 packages and 1 specfiles checked; 1 errors, 0 warnings.
Comment 5 Tomas Orsava 2016-08-23 06:01:49 EDT
Hi Jan!
That's an awesome patch, good work!

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15348756

However, since the changes are not only to the spec file, but you've also added a patch and new sources, it would be highly recommended that you provide a patch that encompasses the changes to the whole git repo, not just the now contents of the spec file. If you'd be interested, I can show you how to do that.
Comment 6 Jan Beran 2016-08-23 14:35 EDT
Created attachment 1193408 [details]
Patch: syntax correction for Python 3.4 and 3.5

Hi Tomáš,

thanks for your review. I attach the patch. If anything else should be done, please let me know.
Comment 7 Jan Beran 2016-09-08 08:40 EDT
Created attachment 1199061 [details]
Update to patched 0.1.17 version including Python 3 subpackage

Adjusted spec file
Comment 8 Jan Beran 2016-09-08 10:12 EDT
Created attachment 1199122 [details]
Update to patched 0.1.17 version including Python 3 subpackage

Added fix of sum/summary.
Comment 9 Dominika Krejčí 2016-09-09 04:01:24 EDT
Hi Jan, I have some comments.

* Please do not add " - Python 2/3 version" to summaries, it is too long, just keep it in descriptions.
* Add %doc README.rst to %files.
Comment 10 Jan Beran 2016-09-09 08:14 EDT
Created attachment 1199444 [details]
Update to patched 0.1.17 version including Python 3 subpackage

Hi Dominika, thank you for the review. I attach the new version updated as required.
Comment 11 Dominika Krejčí 2016-09-23 04:37:03 EDT
Hi Jan, the patch looks good to me now. If maintainer has nothing against, we can push this change after a week.

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15761313
Comment 12 Jan Beran 2016-11-09 02:48 EST
Created attachment 1218839 [details]
Update to new 0.1.18 version including Python 3 subpackage
Comment 13 Charalampos Stratakis 2016-11-18 10:13:45 EST
Fixed in rawhide. If you need this also for F25 please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.