Bug 1311550 - CPU information are 0 in node details, infra provider aggregate nodes CPU
CPU information are 0 in node details, infra provider aggregate nodes CPU
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.7.0
Assigned To: Tzu-Mainn Chen
Marius Cornea
openstack:infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 07:53 EST by Ronnie Rasouli
Modified: 2017-01-04 07:54 EST (History)
5 users (show)

See Also:
Fixed In Version: 5.7.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-04 07:54:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronnie Rasouli 2016-02-24 07:53:58 EST
Description of problem:

CPU details in node, provider summary are 0 


Version-Release number of selected component (if applicable):

5.5.2.4.20160127105142_395c086
RHOS8

How reproducible:

100%

Steps to Reproduce:
1. Login to the Cloudforms UI
2.  Go to the Infrastructure in the primary navigation bar and choose Providers in the secondary navigation bar
3. Click on the Openstack Infrastructure provider virtual thumbnail

Actual results:

in infra provider:
Aggregate Node CPUs, Aggregate Node CPU Cores	are 0

In node details: after SSA
Number of CPUs	Number of CPU Cores	CPU Cores Per Socket	



Expected results:

The infra provider should aggregate the CPU information

The node details for example should retrieve information

[heat-admin@overcloud-novacompute-0 ~]$ lscpu 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             2
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6


Additional info:
Comment 3 Tzu-Mainn Chen 2016-11-03 15:20:11 EDT
should be fixed by https://github.com/ManageIQ/manageiq/pull/8466
Comment 5 errata-xmlrpc 2017-01-04 07:54:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html

Note You need to log in before you can comment on or make changes to this bug.