Bug 1311563 - Missed 'volume' from notification definition blocks remaining notifications to be processed
Missed 'volume' from notification definition blocks remaining notifications t...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Mehdi ABAAKOUK
Yurii Prokulevych
: Triaged, ZStream
Depends On: 1353857
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 08:18 EST by Yurii Prokulevych
Modified: 2016-11-14 14:56 EST (History)
3 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.4-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-14 14:56:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1536699 None None None 2016-02-24 08:18 EST
OpenStack gerrit 311061 None None None 2016-04-29 05:07 EDT

  None (edit)
Description Yurii Prokulevych 2016-02-24 08:18:13 EST
Description of problem:
When meter definition is missing 'volume' keyword all other notifications ain't processed.

E.g. having next definition in meters.yaml:
  - name: "image.size"
    event_type:
      - "image.upload"
      - "image.delete"
      - "image.update"
    type: "gauge"
    unit: B
    project_id: $.payload.owner

Leads to next error:
    2016-01-21 09:20:12.363 12161 ERROR stevedore.extension [-] Could not load 'meter': 'volume'
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension [-] 'volume'
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension Traceback (most recent call last):
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension verify_requirements,
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 187, in _load_one_plugin
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension obj = plugin(*invoke_args, **invoke_kwds)
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension File "/usr/lib/python2.7/site-packages/ceilometer/meter/notifications.py", line 208, in __init__
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension self.definitions = load_definitions(setup_meters_config())
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension File "/usr/lib/python2.7/site-packages/ceilometer/meter/notifications.py", line 188, in load_definitions
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension if (event_def['volume'] != 1 or
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension KeyError: 'volume'
    2016-01-21 09:20:12.365 12161 ERROR stevedore.extension

Version-Release number of selected component (if applicable):


Packages:
ceilometer*-5.0.2-2.el7ost.noarch
Comment 1 Mehdi ABAAKOUK 2016-04-29 05:07:06 EDT
Next upstream Liberty release (5.0.3?) will have the fix.
Comment 5 errata-xmlrpc 2016-11-14 14:56:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2714.html

Note You need to log in before you can comment on or make changes to this bug.