Bug 1311569 - [RFE] IPA: resolve external group memberships of IPA groups during getgrnam and getgrgid
[RFE] IPA: resolve external group memberships of IPA groups during getgrnam a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.3
All Linux
high Severity high
: rc
: ---
Assigned To: SSSD Maintainers
Steeve Goveas
: FutureFeature, ZStream
Depends On: 1300740
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 08:31 EST by Jan Kurik
Modified: 2016-03-31 16:49 EDT (History)
15 users (show)

See Also:
Fixed In Version: sssd-1.13.0-40.el7_2.2
Doc Type: Bug Fix
Doc Text:
Previously, when an Active Directory (AD) user or group was added to an Identity Management (IdM) group using an external IdM group, IdM was unable to resolve the AD user or group before they logged into IdM. With this update, IdM retrieves AD users and groups during group lookups as expected. Additionally, AD members of IdM groups are now successfully resolved. Note that this update allows the slapi-nis Directory Server (DS) plug-in to populate AD group members of IdM groups in the compatibility tree, thus enabling functionality such as group-based sudo rules assignment on legacy clients.
Story Points: ---
Clone Of: 1300740
Environment:
Last Closed: 2016-03-31 16:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-02-24 08:31:27 EST
This bug has been copied from bug #1300740 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 6 Sudhir Menon 2016-03-17 10:09:48 EDT
Verified using
ipa-server-4.2.0-15.el7_2.10.x86_64
sssd-1.13.0-40.el7_2.2.x86_64

[root@host2 ~]# ipa group-add test
------------------
Added group "test"
------------------
  Group name: test
  GID: 1539600006
[root@host2 ~]# ipa group-add --desc='external group' ext_grp --external
---------------------
Added group "ext_grp"
---------------------
  Group name: ext_grp
  Description: external group
[root@host2 ~]# ipa group-add-member ext_grp --external "PNE.QE\group1"
[member user]:
[member group]:
  Group name: ext_grp
  Description: external group
  External member: S-1-5-21-2828791737-1866347024-3967946728-1739
-------------------------
Number of members added 1
-------------------------
 
[root@host2 ~]# ipa group-add-member test
[member user]:
[member group]: ext_grp
  Group name: test
  GID: 1539600006
  Member groups: ext_grp
-------------------------
Number of members added 1
 
[root@host2 ~]# id user1@pne.qe
uid=760201737(user1@pne.qe) gid=760201737(user1@pne.qe) groups=760201737(user1@pne.qe),760200513(domain users@pne.qe),760201739(group1@pne.qe),1539600006(test) <---
 
[root@host2 ~]# id user2@pne.qe
uid=760201738(user2@pne.qe) gid=760201738(user2@pne.qe) groups=760201738(user2@pne.qe),760200513(domain users@pne.qe),760201739(group1@pne.qe),1539600006(test) <---
 
[root@host2 ~]# getent group group1@pne.qe
group1@pne.qe:*:760201739:user1@pne.qe,user2@pne.qe
Comment 8 errata-xmlrpc 2016-03-31 16:49:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0552.html

Note You need to log in before you can comment on or make changes to this bug.