Bug 1311606 - RFE: Add strict domain for confining virtlogd daemon
RFE: Add strict domain for confining virtlogd daemon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 10:13 EST by Daniel Berrange
Modified: 2016-11-03 22:43 EDT (History)
9 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-87.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1311576
Environment:
Last Closed: 2016-11-03 22:43:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2016-02-24 10:13:09 EST
libvirt in RHEL-7.3 is rebasing to version 1.3.1, so we'll want this upstream policy enhancement pulled into RHEL 7.3 too

+++ This bug was initially created as a clone of Bug #1311576 +++

Description of problem:
The virtlogd daemon is currently given the same context as
libvirtd. This is essentially unrestricted host access which
is not at all desirable. The virtlogd daemon is a small single
purpose daemon whose only job is logging. It should have a
dedicated context which strictly controls what it is permitted
todo.

I have written a policy that can do this and submitted upstream

  https://github.com/fedora-selinux/selinux-policy/pull/103
Comment 8 errata-xmlrpc 2016-11-03 22:43:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.