Bug 1311610 - Live storage migration fails due to unassigned disk profile
Live storage migration fails due to unassigned disk profile
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3.2
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Daniel Erez
Aharon Canan
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 10:19 EST by Eyal Shenitzky
Modified: 2016-05-08 03:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-08 03:31:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm logs (11.55 MB, text/plain)
2016-02-24 10:19 EST, Eyal Shenitzky
no flags Details
engine logs (2.51 MB, text/plain)
2016-02-24 10:20 EST, Eyal Shenitzky
no flags Details

  None (edit)
Description Eyal Shenitzky 2016-02-24 10:19:51 EST
Created attachment 1130242 [details]
vdsm logs

Description of problem:

When performing live migration of VM disk to storage-domain with different type
(block -> file and vice-versa) the action fails due to unassigned disk profile error.
The VM created from template as thin.
The template created from thin VM who created from template from glance.
  

Version-Release number of selected component (if applicable):

engine - vdsm-4.17.21-0.el7ev.noarch
vdsm - 4.17.21-0.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. import image from glance as template to domain A. 
2. create vm from the template in step (1) as thin copy on domain A
3. create template from the vm in step (2) on domain A
4. copy the disk of the template in step (3) to domain B that the disk
   should migrate to (different from the source storage domain). 
5. create VM from the template in step (4) as thin copy on domain A
6. move the VM disk to domain B.


Actual results:
Live storage migration fails.

Expected results:
Live storage migration should performed successfully.

Additional info:
Logs of vdsm and engine attached
Comment 1 Eyal Shenitzky 2016-02-24 10:20 EST
Created attachment 1130243 [details]
engine logs
Comment 2 Roy Golan 2016-02-25 07:51:27 EST
2016-02-24 15:18:44,595 WARN  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp-/127.0.0.1:8702-7) [disks_syncAction_9f8b4406-52f3-41ff] CanDoAction of action 'LiveMigrateVmDisks' failed for user admin@internal. Reasons: VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_DISK_PROFILE_NOT_MATCH_STORAGE_DOMAIN,$diskProfile nfs_2,$diskProfileId 37401b5c-40b1-49bd-8fc2-dfed415fd0f0,$storageDomain iscsi_0
2016-02-24 15:18:44,595 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp-/127.0.0.1:8702-7) [disks_syncAction_9f8b4406-52f3-41ff] Lock freed to object 'EngineLock:{exclusiveLocks='[1b91e250-901b-499c-814d-c7fed7e26f61=<DISK, ACTION_TYPE_FAILED_DISK_IS_BEING_MIGRATED$DiskName live_storage_migration_mixed_iscsi_Disk1>]', sharedLocks='[38251a73-7a90-443f-bad0-07740a48a67a=<VM, ACTION_TYPE_FAILED_OBJECT_LOCKED>]'}'
2016-02-24 15:18:44,598 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp-/127.0.0.1:8702-7) [] Operation Failed: [Cannot move Virtual Machine Disk. Disk Profile nfs_2 with id 37401b5c-40b1-49bd-8fc2-dfed415fd0f0 is not assigned to Storage Domain iscsi_0.]

probably can be reproduce without live storage migration. just move a disk to other domain.
Comment 5 Roy Golan 2016-05-08 03:31:42 EDT
Thanks Eyal.

Note You need to log in before you can comment on or make changes to this bug.