Bug 1311612 - virt-manager no longer displays console screen from older systems
virt-manager no longer displays console screen from older systems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 1309913 (view as bug list)
Depends On:
Blocks: F24BetaBlocker
  Show dependency treegraph
 
Reported: 2016-02-24 10:22 EST by Zdenek Kabelac
Modified: 2016-03-03 12:55 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 12:55:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2016-02-24 10:22:34 EST
Description of problem:

In my 'rawhide' setup I'm access remote machine running on RHEL6 
(--connect qemu+ssh)

ARM instead of console VNC screen I just get blank.

It might be related to these logged errors:

DEBUG (connection:803) Error registering domain device removed event: internal error unsupported event ID 15

DEBUG (connection:803) Error registering domain device added event: internal error unsupported event ID 19

DEBUG (connection:829) Error registering network events: unknown procedure: 313


I've even tried to downgrade to: virt-manager-1.2.1-3.fc23.noarch
but no success to get again console working - so possibly I'd need to
downgrade  libvirt as well ?

Not really sure what's the real cause here - so feel free to relocate to right package.


Version-Release number of selected component (if applicable):
virt-manager-1.3.2-2.fc24.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Yanko Kaneti 2016-02-24 10:34:14 EST
This is a virt-manager + gtk3-3.19.9 issue. I've filed gtk regression bug, not sure where the final blame will fall.
https://bugzilla.gnome.org/show_bug.cgi?id=762614
Comment 2 Zdenek Kabelac 2016-02-24 10:52:25 EST
Ohhh 'great victory' then :)

I'm already using  libgtk-3.so.0.1800.6   for preload  when using  firefox nightly, so 'virt-manager' is now just another user :)
(using  export LD_LIBRARY_PATH...)

So yep - with the gtk3 it works again, thanks for quick advice.
Comment 3 Yanko Kaneti 2016-02-25 03:12:53 EST
So gtk got a workaround for cases like these 
https://git.gnome.org/browse/gtk+/commit/?id=dde33623ca3a26ab1c480d918bd86b7f2a24d0f2

at the cost of a runtime warning, which I guess should be addressed in virt-manager code ?


(virt-manager:25122): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size?
Comment 4 Cole Robinson 2016-02-25 10:32:24 EST
*** Bug 1309913 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2016-02-25 10:38:11 EST
Thanks for the info Yanko! So looks like this will be in gtk 3.19.11, moving to gtk3. I'll look at trying to fix the virt-manager side to avoid the warning when I update to f24
Comment 6 John Dulaney 2016-03-02 16:21:30 EST
I should note that this applies to F24 hosting F24, not just older osen.  It also hits a beta release criteria:  The release must be able host virtual guest instances of the same release. I'll be nominating it here directly.
Comment 7 Fedora Blocker Bugs Application 2016-03-02 16:24:32 EST
Proposed as a Blocker for 24-beta by Fedora user jdulaney using the blocker tracking app because:

 The release must be able host virtual guest instances of the same release. 

This bug is causing the virt-manager console to not correctly display.  As virt-manager is considered part of Fedora's recommended virt stack, this bug meets this criteria.
Comment 8 Matthias Clasen 2016-03-03 12:55:05 EST
fixed in 3.19.11

Note You need to log in before you can comment on or make changes to this bug.