Bug 1311641 - virt-viewer can freeze or get into busy loop after forceful unplug of USB device redirected via usbdk
virt-viewer can freeze or get into busy loop after forceful unplug of USB dev...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ovirt-4.0.1
: 4.0.0
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 11:28 EST by David Jaša
Modified: 2016-08-23 16:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-2.0-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
memory dump of 100% cpu 1/2 (15.00 MB, application/x-xz)
2016-02-24 11:28 EST, David Jaša
no flags Details
memory dump of 100% cpu 2/2 (10.47 MB, application/octet-stream)
2016-02-24 11:29 EST, David Jaša
no flags Details

  None (edit)
Description David Jaša 2016-02-24 11:28:41 EST
Created attachment 1130255 [details]
memory dump of 100% cpu 1/2

Description of problem:
This is a follow-up to bug 1149624. UsbDk part of that bug is fixed  but remote-viewer still can e.g. eat 100 % cpu

Version-Release number of selected component (if applicable):
win 7 64b
tools 3.6-6: mingw-virt-viewer 2.0.8, usbdk 1.0-10

How reproducible:


Steps to Reproduce:
1. unplug usb device while redirected
2. wait (or continue working with VM)
3.

Actual results:
virt-viewer process may get to 100 % cpu not reacting to any input or it may just stay around

Expected results:
virt-viewer continues running and exits cleanly when told to do so

Additional info:
join files on linux: cat remote-viewer.DMP.xz.* | xz -dc > remote-viewer.DMP
join files on windows:
Comment 1 David Jaša 2016-02-24 11:29 EST
Created attachment 1130256 [details]
memory dump of 100% cpu 2/2
Comment 2 David Jaša 2016-02-24 11:30:52 EST
join files on windows (YMMV):
copy /b remote-viewer.DMP.xz.00 + remote-viewer.DMP.xz.01 remote-viewer.DMP.xz
Comment 3 Yaniv Lavi 2016-05-09 07:07:01 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 16 errata-xmlrpc 2016-08-23 16:48:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1681.html

Note You need to log in before you can comment on or make changes to this bug.