This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1311695 - EAP7 (insecure, standalone) is discovered incorrectly by agent using old plugin ( 6 != 7 )
EAP7 (insecure, standalone) is discovered incorrectly by agent using old plug...
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.3.5
x86_64 Linux
high Severity medium
: DR02
: One-off release
Assigned To: Simeon Pinder
Mike Foley
: Triaged
: 1313209 1313213 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 13:37 EST by vsorokin
Modified: 2016-10-31 21:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313209 1313213 (view as bug list)
Environment:
Last Closed: 2016-03-07 12:35:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vsorokin 2016-02-24 13:37:02 EST
Description of problem:

EAP7 is discovered incorrectly by agent using old plugin (update02). 
It should be fixed when updated to update03, but still remains.

Version-Release number of selected component (if applicable):
JON 3.3.5 (Foreman's group JON/Server/JON3.3.0/CP5), 
EAP7
JON agents, updated while test running 

Steps to Reproduce:
1. VM1: creating JON3.3 through Foreman, after foreman's installation plugins are 'old' (and after any restarts as well)
2. VM2: install JON agent from foreman, install EAP7 (insecure, standalone)
3. VM1: updating JON plugins by copying *.jars into 'plugins/'. Restart JON.
4. VM2: through Agent console mode update plugins from agent's side
5. VM1: in JON GUI go -> 'Servers - Top Level Import'

Actual results:

Availability as GREEN
Type: 'JBossAS7 Standalone server'
Version: 'EAP 7.0.0.GA'
but Description: still  'Standalone JBoss Enterprise Application Platform 6 server'

Expected results:
Description: still  'Standalone JBoss Enterprise Application Platform 7 server'

Additional info:
intermediate result (between items 2./3.):
Availability as RED
Type: 'JBossAS7 Standalone server'
Version: 'EAP 7.0.0.GA'
but Description: still  'Standalone JBoss Enterprise Application Platform 6 server'
Comment 1 Michael Burman 2016-02-29 08:38:36 EST
We don't do ProductType rediscovery currently. So if you update EAP6 to say JDG, this would fail as well (this isn't EAP7 related).
Comment 2 Filip Brychta 2016-03-03 12:14:39 EST
*** Bug 1313213 has been marked as a duplicate of this bug. ***
Comment 3 Filip Brychta 2016-03-03 12:14:57 EST
*** Bug 1313209 has been marked as a duplicate of this bug. ***
Comment 4 Filip Brychta 2016-03-07 12:35:34 EST
After decision to create dedicated plugin for eap7 and to force eap6 plugin not to discover eap7 resources this is no longer a valid bz

Note You need to log in before you can comment on or make changes to this bug.