Bug 1311717 - Red Hat repositories can edit neither "Mirror On Sync" nor "Download Policy" in UI
Red Hat repositories can edit neither "Mirror On Sync" nor "Download Policy" ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Justin Sherrill
Roman Plevka
http://projects.theforeman.org/issues...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 14:49 EST by Tom McKay
Modified: 2016-07-27 05:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13889 None None None 2016-04-22 12:08 EDT

  None (edit)
Description Tom McKay 2016-02-24 14:49:36 EST
These two options should be editable even for Red Hat products.
Comment 1 Tom McKay 2016-02-24 14:49:38 EST
Created from redmine issue http://projects.theforeman.org/issues/13889
Comment 3 David Davis 2016-02-29 06:52:21 EST
I would also test out the CLI as part of this bug. It should just work once this is fixed but it's worth testing out.
Comment 4 Bryan Kearney 2016-03-08 00:12:43 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13889 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|d7ad5dc027e3a5f97c5f016df4a64df0baf95d53.
Comment 5 Roman Plevka 2016-03-22 10:20:21 EDT
VERIFIED
on sat6.2 snap4.

download_policy and mirror_on_sync can now be set with all UI, Hammer and API methods:


DOWNLOAD POLICY:
```
# hammer -u admin -p changeme repository update --id 3 --download-policy on_demand
Repository updated
# hammer -u admin -p changeme repository info --id 3
...
Download Policy:    on_demand
...
```
```
# curl -u admin:changeme 'https://my.sat6.server/katello/api/v2/repositories/3' -X PUT -H 'Content-Type: application/json;charset=utf-8' -d '{"download_policy":"background"}'
  {...,"download_policy":"background",...}
```

MIRROR ON SYNC:
```
# hammer -u admin -p changeme repository update --id 3 --mirror-on-sync false
Repository updated
# hammer -u admin -p changeme repository update --id 3 --mirror-on-sync true
Repository updated

```
```
# curl -u admin:changeme 'https://my.sat6.server/katello/api/v2/repositories/3' -X PUT -H 'Content-Type: application/json;charset=utf-8' -d '{"mirror_on_sync":false}'
  {"content_type":"yum","docker_upstream_name":null,"mirror_on_sync":false,...}

# curl -u admin:changeme 'https://my.sat6.server/katello/api/v2/repositories/3' -X PUT -H 'Content-Type: application/json;charset=utf-8' -d '{"mirror_on_sync":true}'
  {"content_type":"yum","docker_upstream_name":null,"mirror_on_sync":true,...}

```
Comment 8 errata-xmlrpc 2016-07-27 05:02:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.