Bug 1311731 - Business Central Does Not Support Modern SSH HostKeyAlogrithms
Business Central Does Not Support Modern SSH HostKeyAlogrithms
Status: CLOSED DUPLICATE of bug 1294690
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexandre Porcelli
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 15:46 EST by Justin Holmes
Modified: 2016-03-02 08:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 08:11:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Holmes 2016-02-24 15:46:46 EST
Description of problem:
When trying to use ssh as the protocol to interact with Business Central git repositories on a host with a openssh 7+, Business Central does not provide a compatible HostKeyAlgorithm out of the box, as it only supports ssh-dss which is deprecated in openssh 7+. This forces the user edit their ssh config, and is a nasty paper cut bug.

http://www.openssh.com/legacy.html

Version-Release number of selected component (if applicable):
BPMS 6.x

How reproducible:
100%

Steps to Reproduce:
1. Create a repo in Business Central
2. Clone repo using ssh syntax on a host with openssh 7 (e.g. Fedora 23)
3.

Actual results:
Error message. To fix, one must edit there ssh config. http://www.openssh.com/legacy.html

Expected results:
Repo clones to host.


Additional info:
Comment 2 Alexandre Porcelli 2016-03-02 08:11:42 EST

*** This bug has been marked as a duplicate of bug 1294690 ***

Note You need to log in before you can comment on or make changes to this bug.