Bug 1311740 - Upgrade Spring Framework to 4.2.4
Upgrade Spring Framework to 4.2.4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-dependencies (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Sandro Bonazzola
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 15:58 EST by Martin Perina
Modified: 2016-08-24 02:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Rebase Spring Framework to 4.2.4
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 02:09:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Perina 2016-02-24 15:58:55 EST
Description of problem:

Upgrade Spring Framework provided by rhevm-dependencies to version 4.2.4, which is currently required by oVirt 4.0

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Sandro Bonazzola 2016-03-11 04:08:32 EST
Martin, 4.2.4 is missing spring-asm which was in 3.1.1. 
Do you need a replacement for it? Or can I just drop it?
Comment 2 Martin Perina 2016-03-11 04:12:28 EST
spring-asm was removed from SpringFramework 4 and it's functionality was reimplemented inside spring-core, so we don't need it anymore
Comment 3 Pavol Brilla 2016-07-01 04:58:11 EDT
# rpm -ql rhevm-dependencies | grep -i spring | grep 4.2.4
/usr/share/java/rhevm-dependencies/spring-aop-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-beans-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-context-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-core-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-expression-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-instrument-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-jdbc-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-test-4.2.4.RELEASE.jar
/usr/share/java/rhevm-dependencies/spring-tx-4.2.4.RELEASE.jar

Note You need to log in before you can comment on or make changes to this bug.