Bug 1311763 - Tempest setup of some volume tests is failing with 8-director on baremetal
Tempest setup of some volume tests is failing with 8-director on baremetal
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Angus Thomas
Arik Chernetsky
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 17:54 EST by Steve Linabery
Modified: 2016-10-13 18:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-13 18:04:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Linabery 2016-02-24 17:54:43 EST
Description of problem:

These tempest setups are failing consistently on baremetal with the puddle bits:

1) .setUpClass (tempest.api.volume.test_volumes_actions.VolumesV1ActionsTest)

Traceback (most recent call last):
testtools.testresult.real._StringException: Traceback (most recent call last):
  File "/home/stack/tempest/tempest/test.py", line 262, in setUpClass
    six.reraise(etype, value, trace)
  File "/home/stack/tempest/tempest/test.py", line 255, in setUpClass
    cls.resource_setup()
  File "/home/stack/tempest/tempest/api/volume/test_volumes_actions.py", line 45, in resource_setup
    cls.volume = cls.create_volume()
  File "/home/stack/tempest/tempest/api/volume/base.py", line 116, in create_volume
    cls.volumes_client.wait_for_volume_status(volume['id'], 'available')
  File "/home/stack/tempest/tempest/services/volume/base/base_volumes_client.py", line 153, in wait_for_volume_status
    waiters.wait_for_volume_status(self, volume_id, status)
  File "/home/stack/tempest/tempest/common/waiters.py", line 174, in wait_for_volume_status
    raise exceptions.VolumeBuildErrorException(volume_id=volume_id)
tempest.exceptions.VolumeBuildErrorException: Volume 5c091d58-1482-4c48-9fd0-b7d30e4152f9 failed to build and is in ERROR status



2) .setUpClass (tempest.api.volume.test_volumes_list.VolumesV1ListTestJSON)

Traceback (most recent call last):
testtools.testresult.real._StringException: Traceback (most recent call last):
  File "/home/stack/tempest/tempest/test.py", line 262, in setUpClass
    six.reraise(etype, value, trace)
  File "/home/stack/tempest/tempest/test.py", line 255, in setUpClass
    cls.resource_setup()
  File "/home/stack/tempest/tempest/api/volume/test_volumes_list.py", line 66, in resource_setup
    volume = cls.create_volume(metadata=cls.metadata)
  File "/home/stack/tempest/tempest/api/volume/base.py", line 116, in create_volume
    cls.volumes_client.wait_for_volume_status(volume['id'], 'available')
  File "/home/stack/tempest/tempest/services/volume/base/base_volumes_client.py", line 153, in wait_for_volume_status
    waiters.wait_for_volume_status(self, volume_id, status)
  File "/home/stack/tempest/tempest/common/waiters.py", line 174, in wait_for_volume_status
    raise exceptions.VolumeBuildErrorException(volume_id=volume_id)
tempest.exceptions.VolumeBuildErrorException: Volume a0fafcf9-59a9-40e0-9c84-c07b6457fe81 failed to build and is in ERROR status

Filing them in the same BZ since it looks like the same root cause from the stacktraces.
Comment 3 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Jaromir Coufal 2016-10-11 09:32:26 EDT
Might be storage or Tempest issue.

Note You need to log in before you can comment on or make changes to this bug.