This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1311766 - Cockpit filter option not filtering out project specific details
Cockpit filter option not filtering out project specific details
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter
qe-baseos-daemons
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 18:14 EST by Eric Jones
Modified: 2016-11-10 11:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Atomic Enterprise Platform
Last Closed: 2016-11-10 11:29:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of specifying different project and still seeing default services (161.27 KB, image/png)
2016-02-24 18:15 EST, Eric Jones
no flags Details

  None (edit)
Description Eric Jones 2016-02-24 18:14:24 EST
Description of problem:
Customer indicated that he is able to see services and other details that are specific to one project/namespace while filtering on for a different project/namespace.

Version-Release number of selected component (if applicable):
Customer just upgraded cockpit to 0.93

How reproducible:
100% for the customer

Steps to Reproduce:
1. Identify a service (like kubernetes) in the default project
2. Change the "Project" filter in the top left corner of the screen to a different project

Actual results:
Still see the same service (like kubernetes) while "filtering" for a different project

Expected results:
Only see services for the project you are "filtering" for.
Comment 1 Eric Jones 2016-02-24 18:15 EST
Created attachment 1130362 [details]
Example of specifying different project and still seeing default services
Comment 2 Andy Goldstein 2016-02-24 18:17:44 EST
Shouldn't this be filed under RHEL7/cockpit?
Comment 3 Eric Jones 2016-02-24 18:23:15 EST
Yes, yes it should. Sorry Andy.
Comment 5 Peter 2016-04-27 09:32:17 EDT
I'm not able to reproduce, on either the current release (0.103) or 0.93. Quite a bit has changed between those two versions including the way the filter works. If you are able to reproduce on 0.103, it is only the topology view that has this bug?  Does the problem happen with other services than the default kubernetes one? what about other namespaces?
Comment 8 Dominik Perpeet 2016-11-10 11:29:45 EST
Filtering should work correctly in the current release, as Peter said significant work has been done there. Please open a new bug if this happens on a newer version.

Note You need to log in before you can comment on or make changes to this bug.