Bug 1311770 - Import Vm from vmware fail
Import Vm from vmware fail
Status: CLOSED DUPLICATE of bug 1292096
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.21
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Dan Kenigsberg
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 19:04 EST by Andrey Amado
Modified: 2016-03-02 11:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 03:11:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Andrey Amado 2016-02-24 19:04:17 EST
Description of problem: import vmware fail because curl is malformed.


Version-Release number of selected component (if applicable):
Node: oVirt Node Hypervisor release 3.6 (0.999.201602221022.el7.centos)
engine: ovirt-engine-3.6.2.6-1.el6.noarch
Vsphere 5.5


How reproducible: I tried import vm from v2v integrate (external provider) and I can see the list of shutdown vm's, but the start import process it fail with the next message on the node:

Feb 24 22:19:45 nodo journal: vdsm root ERROR Job u'4236f3cf-4401-519b-6e8f-332678a70ae5' failed#012Traceback (most recent call last):#012  File "/usr/share/vdsm/v2v.py", line 415, in _run#012    self._import()#012  File "/usr/share/vdsm/v2v.py", line 451, in _import#012    self._proc.stderr.read(1024)))#012V2VProcessError: Job u'4236f3cf-4401-519b-6e8f-332678a70ae5' process failed exit-code: 1, stderr: curl -q --insecure --user '<hidden>' --head --silent --url 'https://10.xx.9.xx/folder/NAMEX/NAMEX-flat.vmdk?dcPath=Datacentername/Clustername&dsName=Datastorename'#012HTTP/1.1 404 Not Found#015#012Date: Wed, 24 Feb 2016 22:00:47 GMT#015#012Set-Cookie: vmware_soap_session="52f10bd7-0297-5061-5a73-41a61aa3bec2"; Path=/; HttpOnly; Secure; #015#012Connection: close#015#012Content-Type: text; charset=plain#015#012Content-Length: 0#015#012#015#012virt-v2v: error: vcenter: URL not found: #012https://10.xx.9.xx/folder/NAMEX/NAMEX-flat.vmdk?dcPath=Datacentername/Clustername&dsName=Datastorename#012#012The '--dcpath' parameter may be useful.  See the explanation in the #012virt-v2v(1) man page OPTIONS section.#012#012If reporting bugs, run virt-v2v with debugging enabled and include the #012complete output:#012#012  virt-v2v -v -x [...]



Steps to Reproduce:
1.Import vm from vmware external provider
2. start the process of import
3. fail

Actual results: The import process is not possible.


Expected results: The successful import of vm.


Additional info: 
I test the url from the vcenter and the correct url is:
https://10.xx.9.xx/folder/NAMEX/NAMEX-flat.vmdk?dcPath=Datacentername&dsName=Datastorename

the cluster name is the cause of error.
Comment 1 Tomas Jelinek 2016-03-01 03:39:27 EST
It seems you are hitting: https://bugzilla.redhat.com/show_bug.cgi?id=1292437 and https://bugzilla.redhat.com/show_bug.cgi?id=1263574

The issue is in libguesfs and libvirt. Not sure what versions are you using... Could you please try with this ones?

libvirt-1.3.1-1.el7.x86_64
libguestfs-1.32.2-6.el7.x86_64
virt-v2v-1.32.2-6.el7.x86_64

Thank you
Comment 2 Andrey Amado 2016-03-01 09:56:28 EST
sure, I will find the packages and report the result.
Comment 3 Andrey Amado 2016-03-01 10:06:34 EST
my version are:
virt-v2v-1.28.1-1.55.el7.centos.x86_64
libguestfs-1.28.1-1.55.el7.centos.x86_64
libvirt-daemon-kvm-1.2.17-13.el7_2.3.x86_64
Comment 4 Tomas Jelinek 2016-03-02 03:11:52 EST
Adrey: please ignore the comment 1 - it is a different issue, but already tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1292096 - so closing this as duplicate. Please follow this to see when it is going to be fixed.

*** This bug has been marked as a duplicate of bug 1292096 ***
Comment 5 Andrey Amado 2016-03-02 11:11:05 EST
Ok, thanks for you help..

greetings..

Note You need to log in before you can comment on or make changes to this bug.