Bug 1311792 - [Tracker] RHSC tracker for objdump -S disassembly code doesn't follow /usr/lib/debug/.... conventions, so can't find sources
[Tracker] RHSC tracker for objdump -S disassembly code doesn't follow /usr/l...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.3.2
Unspecified Unspecified
low Severity low
: rc
: 1.3.4
Assigned To: Brad Hubbard
ceph-qe-bugs
: Tracking
Depends On: 1311352
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 20:30 EST by Brad Hubbard
Modified: 2017-07-30 11:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 23:24:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hubbard 2016-02-24 20:30:20 EST
Description of problem:

Tracking this since it's kind of important to Ceph and may involve more than one BZ. Also to aid searching for this in the Ceph name-space and so we know when it's resolved. The result of this issue for ceph is that the command we recommend in our backtrace dumps to the logs, objdump -rdS <binary>, does not actually produce the desired output including inlined source code.

NOTE: This is not a Ceph issue.

See bz1311352 For details

Note You need to log in before you can comment on or make changes to this bug.