Bug 1311795 - DVD installer images produced by Pungi 4 fail to boot due to incorrect inst.stage2 parameter
DVD installer images produced by Pungi 4 fail to boot due to incorrect inst.s...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F24AlphaBlocker
  Show dependency treegraph
 
Reported: 2016-02-24 20:54 EST by Adam Williamson
Modified: 2016-02-29 19:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 19:02:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2016-02-24 20:54:06 EST
The inst.stage2 parameter in the boot menu entries for Server DVD images produced by Pungi 4 looks like this:

inst.stage2=hd:LABEL=Fedora-S-boot-x86_64-(version)

this is incorrect. Note the '-boot-'. It should be '-dvd-'. Due to this error, the images do not boot. If you manually edit the cmdline and change -boot- to -dvd-, the images boot OK.

Verified with https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20160222.n.0/compose/Server/x86_64/iso/Fedora-Server-dvd-x86_64-Rawhide-20160222.n.0.iso and https://kojipkgs.fedoraproject.org/compose/branched/Fedora-24-20160224.n.0/compose/Server/x86_64/iso/Fedora-Server-dvd-x86_64-24-20160224.n.0.iso (so both Rawhide and 24).

This is an automatic Fedora 24 Alpha blocker: "Complete failure of any release-blocking TC/RC image to boot at all under any circumstance - "DOA" image (conditional failure is not an automatic blocker)". We don't technically have a TC yet, but this issue would certainly affect one.
Comment 1 Adam Williamson 2016-02-24 20:55:23 EST
I believe the parameter is actually produced in lorax - in share/templates.d/99-generic/x86.tmpl , specifically - but I *think* the isolabel value that uses is ultimately passed in from Pungi. I tried to figure out how the Server DVD compose process actually works, but couldn't grok it, or find any relevant logs.
Comment 2 Adam Williamson 2016-02-29 19:02:02 EST
This seems to be resolved in the last few composes (both 24 and Rawhide), they're now reaching anaconda and blowing up on the glibc langpack problem.

Note You need to log in before you can comment on or make changes to this bug.