Bug 131181 - ENH: Have RPM's Obsoletes Tag Work For Files/Dirs
Summary: ENH: Have RPM's Obsoletes Tag Work For Files/Dirs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-28 13:32 UTC by Jeff Pitman
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-17 18:28:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Pitman 2004-08-28 13:32:27 UTC
Description of problem: 
 
Sometimes it is difficult to get a set of possible packages setup for 
Obsoletes.  One way to make things easier is to be able to Obsolete a 
common file or directory shared among these sets of packages. 
 
Version-Release number of selected component (if applicable): 
 
4.3.1 
 
Example Tag: 
 
Obsoletes: /usr/lib/python2.3 
 
Actual results: 
 
error: line 17: File name not permitted: 
Obsoletes: /usr/lib/python2.3 
 
Expected results: 
 
Successful SPEC compile with filename or directory obsoletes.

Comment 1 Jeff Johnson 2004-10-17 18:28:05 UTC
Added to rpm cvs HEAD, should be in rpm-4.4.


Note You need to log in before you can comment on or make changes to this bug.