Bug 1311822 - rebalance : output of rebalance status should show ' run time ' in proper format (day,hour:min:sec)
rebalance : output of rebalance status should show ' run time ' in proper for...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.9
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sakshi
: Triaged
Depends On: 1223625
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 00:30 EST by Sakshi
Modified: 2016-07-31 21:22 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1223625
Environment:
Last Closed: 2016-04-15 01:15:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2016-02-25 00:30:50 EST
+++ This bug was initially created as a clone of Bug #1223625 +++

+++ This bug was initially created as a clone of Bug #1034116 +++

Description of problem:
rebalance status output shows run time in sec which is hard to read when no. is big

e.g

[root@7-VM1 core]#  gluster volume rebalance flat status
                                    Node Rebalanced-files          size       scanned      failures       skipped         status run time in secs
                               ---------      -----------   -----------   -----------   -----------   -----------   ------------   --------------
                               localhost           832000        13.7GB       5344344             1           228         failed        159836.00
                            10.70.36.133          1009405        15.7GB       5362837             2           206         failed        159836.00
                            10.70.36.132           823206        12.9GB       5416604             1           233         failed        159836.00
                            10.70.36.131                0        0Bytes       5227829             0             0         failed        159836.00
volume rebalance: flat: success: 

It's better to show output as '1 day, XX:XX:XX' or "Hour:min:sec" then '5227829'

Version-Release number of selected component (if applicable):
============================================
3.4.0.44rhs-1.el6rhs.x86_64




Actual results:
run time is always displayed in sec.

Expected results:
Hour:min:Sec format is better than only seconds 

Additional info:

--- Additional comment from Anand Avati on 2015-05-21 00:26:29 EDT ---

REVIEW: http://review.gluster.org/10544 (dht: Output of rebalance to show run time in proper format) posted (#3) for review on master by Sakshi Bansal (sabansal@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-17 05:49:47 EST ---

REVIEW: http://review.gluster.org/10544 (cli : output of rebalance to show run time in proper format) posted (#6) for review on master by Sakshi Bansal

--- Additional comment from Vijay Bellur on 2016-02-03 07:01:59 EST ---

REVIEW: http://review.gluster.org/10544 (cli: output of rebalance to show run time in proper format) posted (#7) for review on master by Sakshi Bansal

--- Additional comment from Vijay Bellur on 2016-02-25 00:10:30 EST ---

COMMIT: http://review.gluster.org/10544 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 77245bcbf02754dec832ca34a9138bade2c9cfa3
Author: Sakshi <sabansal@redhat.com>
Date:   Tue May 5 10:55:56 2015 +0530

    cli: output of rebalance to show run time in proper format
    
    Change-Id: I775f13c8046dd2aeb9d4b86a737dcebb396778b4
    BUG: 1223625
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/10544
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Vijay Bellur 2016-02-25 00:33:17 EST
REVIEW: http://review.gluster.org/13514 (cli: output of rebalance to show run time in proper format) posted (#1) for review on release-3.7 by Sakshi Bansal
Comment 2 Vijay Bellur 2016-02-25 23:54:51 EST
REVIEW: http://review.gluster.org/13514 (cli: output of rebalance to show run time in proper format) posted (#2) for review on release-3.7 by Sakshi Bansal
Comment 3 Vijay Bellur 2016-02-26 01:32:39 EST
REVIEW: http://review.gluster.org/13514 (cli: output of rebalance to show run time in proper format) posted (#3) for review on release-3.7 by Sakshi Bansal
Comment 4 Vijay Bellur 2016-02-29 08:14:48 EST
REVIEW: http://review.gluster.org/13514 (cli: output of rebalance to show run time in proper format) posted (#4) for review on release-3.7 by Sakshi Bansal
Comment 5 Vijay Bellur 2016-02-29 23:54:30 EST
COMMIT: http://review.gluster.org/13514 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 0cdfd1aa02b0f5f6483fd56625bc032060694a93
Author: Sakshi <sabansal@redhat.com>
Date:   Tue May 5 10:55:56 2015 +0530

    cli: output of rebalance to show run time in proper format
    
    Backport of http://review.gluster.org/#/c/10544/
    
    Modified tests to parse the new rebalance time format.
    
    > Change-Id: I775f13c8046dd2aeb9d4b86a737dcebb396778b4
    > BUG: 1223625
    > Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    > Reviewed-on: http://review.gluster.org/10544
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    BUG: 1311822
    Change-Id: I3c8106f7a1309f154861ce1b3efa202fa6c47c57
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13514
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 6 Kaushal 2016-04-19 03:22:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.