Bug 1311832 - id_query option is not available after rebasing openldap to 2.4.39.
id_query option is not available after rebasing openldap to 2.4.39.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openldap (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matus Honek
Patrik Kis
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 01:55 EST by Karel Srot
Modified: 2016-11-03 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288545
Environment:
Last Closed: 2016-11-03 19:41:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenLDAP ITS 8329 None None None 2016-02-25 01:55 EST

  None (edit)
Description Karel Srot 2016-02-25 01:55:57 EST
The bug is present on RHEL-7 too, tested with openldap-2.4.40-8.el7.x86_64

+++ This bug was initially created as a clone of Bug #1288545 +++

Description of problem:
After updating the OpenLDAP package from version 2.4.23-34.el6_5.1 to version 2.4.40-7 openldap is not working with mysql backend.
Below error can be seen in slapd.log file.

------
Dec  1 16:40:13 testldap00 slapd[3392]: line 33 (dbpasswd ***)
Dec  1 16:40:13 testldap00 slapd[3392]: line 34 (readonly#011on)
Dec  1 16:40:13 testldap00 slapd[3392]: line 36 (id_query "SELECT id, keyval, oc_map_id, dn FROM ldap_entries WHERE pop_username = ?")
Dec  1 16:40:13 testldap00 slapd[3392]: /etc/openldap/slapd.conf: line 36: unknown directive <id_query> inside backend database definition.
Dec  1 16:40:13 testldap00 slapd[3392]: slapd destroy: freeing system resources.
Dec  1 16:40:13 testldap00 slapd[3392]: ==>backsql_db_destroy()
------

Customer has observed that, in the openldap code, "id_query has been removed from servers/slapd/back-sql/config.c" after rebasing the openldap package to 2.4.39.

Version-Release number of selected component (if applicable):
openldap-2.4.40-7


Additional info:
Customer has submitted a upstream bug report (ITS#8329) and patch to openldap the same will be included in next release.

I am attaching the patch file for reference.

--- Additional comment from Matus Honek on 2015-12-08 07:08:41 EST ---

Respective upstream commits are:
33ed03a64b581503057e3a3498c0afac72c493f2 (original patch)
af0c7ae038dac888d9fd39d577562f669c834b50 (fix)

For correct fix one needs to apply both commits/patches above.
Comment 8 errata-xmlrpc 2016-11-03 19:41:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2163.html

Note You need to log in before you can comment on or make changes to this bug.