Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1311846 - OS release version not attached to a copied Activation Key correclty
OS release version not attached to a copied Activation Key correclty
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys (Show other bugs)
6.1.6
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: Unused
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 02:53 EST by Frank Reimer
Modified: 2017-08-04 09:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 09:19:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Reimer 2016-02-25 02:53:42 EST
Description of problem:
I`ve created an Activation Key and attached a "Release Version" on the Details tab to the Activation Key. I also configured all other needed things like product content, subscriptions and so on. 

If I now copy this Activation Key the Release Version seems to be present at the copied Activation Key. But when I try to install a new client with the copied Activation Key which for example has 7.2 as a release version then the client does not configure the release version via subscription-manager correctly during provisioning. This leads to the problem that the client is not able to access the correct RHEL Yum repositories on Satellite.

If I open the copied Activation Key again, delete the release version and attach the release version again, then the client can successfully access all needed Yum repositories with this specific release version during provisioning. 

Version-Release number of selected component (if applicable):
- Satellite 6.1.6
- RHEL 7.2

How reproducible:
- Copy an Activation Key with "Release Version" configured.

Steps to Reproduce:
1. Copy an Activation Key with "Release Version" configured.
2. Do not change anything regarding "Release Version"


Actual results:
The release version seems to be configured at the copied Activation Key without taking effect.

Expected results:
If an activation key will be copied then I expect every parameter configured at the parent activation key will also be configured correctly at the copied activation key without any manual interventions. 

Additional info:
Comment 2 Bryan Kearney 2016-07-26 15:03:33 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Bryan Kearney 2017-08-04 09:19:04 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.