Bug 1311856 - Satellite repositories should not be forcibly disabled
Satellite repositories should not be forcibly disabled
Status: CLOSED DUPLICATE of bug 1311859
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Jiri Stransky
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 03:36 EST by David Juran
Modified: 2016-04-18 03:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 07:50:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2016-02-25 03:36:37 EST
Description of problem:
The rhel-registration script in /usr/share/openstack-tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/scripts/ forcibly disables the repository rhel-7-server-rh-common-rpms

When an OverCloud node is registered to an Red Hat Satellite 6, it's presumably to enable life-cycle management of the software on the node. I.e. to enable the ability to publish a Content View and thereby ensuring that consistent and updated repositories are available to the OverCloud nodes. Which repositories are made available is typically controlled by the administrator in the Aktivation Key (specified in rhel_reg_activation_key).

The problem is that the above mentioned script, on line 127, forcibly disables the repository rhel-7-server-rh-common-rpms. With this repository disabled, no errata related to any package in this repository, e.g. cloud-init, can be published to an OverCloud node. 



Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-121.el7ost.noarch
Comment 2 Mike Burns 2016-02-25 07:50:47 EST

*** This bug has been marked as a duplicate of bug 1311859 ***

Note You need to log in before you can comment on or make changes to this bug.