Bug 1311858 - Press Alt key and Caps Lock has to not changed but changed in spice console.
Press Alt key and Caps Lock has to not changed but changed in spice console.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.5.6
Unspecified Unspecified
urgent Severity urgent
: ovirt-4.0.0-rc
: ---
Assigned To: Fabiano Fidêncio
SPICE QE bug list
: OtherQA, ZStream
Depends On: spice_japanese_keyboard 1329600
Blocks: 1332622
  Show dependency treegraph
 
Reported: 2016-02-25 03:37 EST by Yoshinori Takahashi
Modified: 2016-08-23 16:49 EDT (History)
19 users (show)

See Also:
Fixed In Version: mingw-spice-gtk-0.31-2.el7ev mingw-virt-viewer-2.0-10.el7ev rhevm-spice-client-4.0-2
Doc Type: Bug Fix
Doc Text:
Previously, Eisu key combinations were not working properly when using spice-gtk. Now, support for Eisu/Alt + Eisu keys has been added to spice-gtk.
Story Points: ---
Clone Of:
: 1332622 (view as bug list)
Environment:
Last Closed: 2016-08-23 16:49:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot without ImmDisableIME (542.09 KB, image/png)
2016-04-15 06:07 EDT, fujiwara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 763736 None None None 2016-03-16 05:51 EDT

  None (edit)
Comment 1 Fabiano Fidêncio 2016-02-25 15:39:05 EST
Yoshinori Takahashi,

Does this problem only happen with one specific keyboard model? Which one? When did you start noticing these issues? What's the workaround found by the user?

Please, apart from your answers to the questions above, I would like to ask you to provide the remote-viewer log.

For doing this, you'll need to:
1) Download debug-helper binary and place it where remote-viewer.exe resides. You can get the binary from: http://fidencio.fedorapeople.org/debug-helper.exe
2) Download gdb binary and place it where remote-viewer.exe resides. You can get the binary from: http://fidencio.fedorapeople.org/gdb.exe
3) On RHEV-M Portal, choose to use the "Native client".
4) Click in "Console" and save the vv-file
5) Open a Cmd
6) Go where remote-viewer.exe resides and run: debug-helper remote-viewer.exe vv-file

You should see a Cmd window running gdb that will print stdout/stderr of remote-viewer.exe. Copy the whole output from there and attach to this bug report.

Please, keep in mind that it will generate a really big amount of debug. So, try to do the minimum interaction possible for providing us the logs for this specific bug and give us a detailed step-by-step about what you did when getting the logs.
Also, if you have an easy access to a bare metal Linux machine, I'd be really interested in getting the scancode of these problematic keys.
Comment 14 Frediano Ziglio 2016-03-10 06:05:57 EST
All these bugs are quite confusing.

First: how virt-viewer/remote-viewer should work: send raw key to remote machine. No IME should be involved. The expected behavior of other client applications does not matter, the fact that client is connecting from a Windows machine or Linux or Mac should not change the expected behavior.

Second: what is the guest configuration? This is the behavior the customer should expect, no matter what client is using. What the behavior of RHEL-7 set with Japanese pressing Alt-CapsLock? Better to test with physical (bare metal) machine, if not possible try with Qemu locals (SDL/GTK/others) or if not possible remotes (VNC/Spice) but better first options.
Comment 15 fujiwara 2016-03-11 03:50:39 EST
Probably I think this is not relative with IME and Alt key.

Client: English (US) keyboard on Windows 7 Japanese edition
Virtual Host: Only US keyboard on RHEL 7 GNOME

When I type CapsLock, The lock is ON but when I type CapsLock again, the lock cannot be OFF.
Comment 19 Frediano Ziglio 2016-03-11 05:14:21 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1311804#c14 for reason why caps lock have problems with Japanese keyboards.
Comment 21 Frediano Ziglio 2016-03-11 05:30:04 EST
No, it's IMHO a client problem, not a guest one.
Comment 34 Frediano Ziglio 2016-04-11 11:49:37 EDT
Does the patch work for the customer ?
Comment 38 Frediano Ziglio 2016-04-14 07:19:55 EDT
Also, can we have the sources or the commit id (the hash) or the sources?
Comment 41 Frediano Ziglio 2016-04-15 05:37:14 EDT
The ImmDisableIME is not necessary only if you have the grab of the keyboard.
This as the windows hook which is installed when you have the keyboard grabbed receives the messages before IME change them. Try to click on the title, keep mouse there and press some keys, they won't work if IME is enabled.
Comment 42 fujiwara 2016-04-15 06:07 EDT
Created attachment 1147585 [details]
Screenshot without ImmDisableIME

(In reply to Frediano Ziglio from comment #41)
> The ImmDisableIME is not necessary only if you have the grab of the keyboard.
> This as the windows hook which is installed when you have the keyboard
> grabbed receives the messages before IME change them. Try to click on the
> title, keep mouse there and press some keys, they won't work if IME is
> enabled.

My understanding is you mean the problem with the attaching screenshot, it cannot send the key events if the local IME enables Hiragana.
I think it may be vice-versa.

ImmDisableIME always can send the key events.
No ImmDisableIME can show the keyboard status and users can change it.

I'd like to ask the users which is preferred.
Comment 44 fujiwara 2016-04-25 04:28:09 EDT
The customers verified the reported bugs are fixed with the test binary which were built from virt-viewer 0.6.0-34 with the patches in comment #43.
I think the bug 1311820, bug 1311858 and bug 1311804 are fixed and bug 1297640 is duplicated of bug 1311820.

Could you commit the patches in mingw-spice-gtk?
The customer wishes the signed virt-viewer.msi asap.
Comment 45 Fabiano Fidêncio 2016-04-25 06:46:44 EDT
(In reply to fujiwara from comment #44)
> The customers verified the reported bugs are fixed with the test binary
> which were built from virt-viewer 0.6.0-34 with the patches in comment #43.
> I think the bug 1311820, bug 1311858 and bug 1311804 are fixed and bug
> 1297640 is duplicated of bug 1311820.
> 
> Could you commit the patches in mingw-spice-gtk?
> The customer wishes the signed virt-viewer.msi asap.
Comment 46 fujiwara 2016-04-25 23:29:31 EDT
(In reply to Fabiano Fidêncio from comment #45)
> (In reply to fujiwara from comment #44)
> > The customers verified the reported bugs are fixed with the test binary
> > which were built from virt-viewer 0.6.0-34 with the patches in comment #43.
> > I think the bug 1311820, bug 1311858 and bug 1311804 are fixed and bug
> > 1297640 is duplicated of bug 1311820.
> > 
> > Could you commit the patches in mingw-spice-gtk?
> > The customer wishes the signed virt-viewer.msi asap.

Why did you set rhevm-3.6.0?
I think that way is not tested and it can fix my patch1 and patch3 but patch2 is still needed.
I'd think applying my patch1 and patch2 can avoi any regressions.
Comment 48 Yaniv Lavi (Dary) 2016-05-09 07:00:42 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 52 Fabiano Fidêncio 2016-06-07 19:41:59 EDT
Sorry, was moved to MODIFIED by mistake.
Comment 53 Fabiano Fidêncio 2016-06-07 19:42:45 EDT
Ouch, no, it was right. :-\
Comment 57 errata-xmlrpc 2016-08-23 16:49:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1681.html

Note You need to log in before you can comment on or make changes to this bug.