This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1311870 - wrong codemodel paths in /usr/share/ngspice/scripts/spinit
wrong codemodel paths in /usr/share/ngspice/scripts/spinit
Status: CLOSED DUPLICATE of bug 1311869
Product: Fedora
Classification: Fedora
Component: ngspice (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Eduardo Mayorga
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 04:01 EST by Artem Prokshin
Modified: 2016-02-25 04:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 04:47:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem Prokshin 2016-02-25 04:01:32 EST
Description of problem:

File /usr/share/ngspice/scripts/spinit has codemodel paths:

 codemodel /usr/lib64/tclspice/ngspice/spice2poly.cm

* The other codemodels
 codemodel /usr/lib64/tclspice/ngspice/analog.cm
 codemodel /usr/lib64/tclspice/ngspice/digital.cm
 codemodel /usr/lib64/tclspice/ngspice/xtradev.cm
 codemodel /usr/lib64/tclspice/ngspice/xtraevt.cm

but actual place of '.cm'-files is

/usr/lib64/ngspice/

Version-Release number of selected component (if applicable):

ngspice-26-1.fc23.x86_64
The same misconfiguration is in i686 version.

How reproducible:


Steps to Reproduce:
1. make sure tclspice-26-1.fc23.x86_64 is not installed:
dnf remove tclspice

2.make file foo.cir with sample shown in 12.1 Code Model Element & .MODEL Cards of manual /usr/share/doc/ngspice/ngspice-26.pdf

reproduce bug 
* 
a1 1 2 amp 
.model amp gain ( gain =5.0)

3. /bin/ngspice foo.cir

Actual results:


user@localhost bug]$ /bin/ngspice foo.cir
/usr/lib64/tclspice/ngspice/spice2poly.cm: cannot open shared object file: No such file or directory
Error: Library /usr/lib64/tclspice/ngspice/spice2poly.cm couldn't be loaded!
/usr/lib64/tclspice/ngspice/analog.cm: cannot open shared object file: No such file or directory
Error: Library /usr/lib64/tclspice/ngspice/analog.cm couldn't be loaded!
/usr/lib64/tclspice/ngspice/digital.cm: cannot open shared object file: No such file or directory
Error: Library /usr/lib64/tclspice/ngspice/digital.cm couldn't be loaded!
/usr/lib64/tclspice/ngspice/xtradev.cm: cannot open shared object file: No such file or directory
Error: Library /usr/lib64/tclspice/ngspice/xtradev.cm couldn't be loaded!
/usr/lib64/tclspice/ngspice/xtraevt.cm: cannot open shared object file: No such file or directory
Error: Library /usr/lib64/tclspice/ngspice/xtraevt.cm couldn't be loaded!
******
** ngspice-26 : Circuit level simulation program
** The U. C. Berkeley CAD Group
** Copyright 1985-1994, Regents of the University of California.
** Please get your ngspice manual from http://ngspice.sourceforge.net/docs.html
** Please file your bug-reports at http://ngspice.sourceforge.net/bugrep.html
** Creation Date: Sat Oct 10 04:33:45 UTC 2015
******

Circuit: reproduce bug

Error on line 3 : a1 1 2 amp
   MIF-ERROR - unable to find definition of model amp
Warning: Model issue on line 4 : .model amp gain ( gain=5.0) ...
  Unknown model type gain - ignored
ngspice 3735 -> quit
ngspice-26 done


Expected results:


Additional info:
Comment 1 Artem Prokshin 2016-02-25 04:47:12 EST

*** This bug has been marked as a duplicate of bug 1311869 ***

Note You need to log in before you can comment on or make changes to this bug.