Bug 1311873 - Suggest not to change ClientAliveInterval when execute "waagent -install"
Suggest not to change ClientAliveInterval when execute "waagent -install"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
6.7
Unspecified Linux
low Severity low
: rc
: ---
Assigned To: Yue Zhang
Virtualization Bugs
:
Depends On:
Blocks: 1366045 1359574 1387784
  Show dependency treegraph
 
Reported: 2016-02-25 04:10 EST by yuxisun@redhat.com
Modified: 2016-11-16 01:20 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-09 01:17:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuxisun@redhat.com 2016-02-25 04:10:20 EST
Description of problem:
The "waagent -install" changes the ClientAliveInterval to 180 in
/etc/ssh/sshd_config. It seems that it's not very good and necessary to
change customer's configuration. It's not mentioned in
https://github.com/Azure/WALinuxAgent/tree/WALinuxAgent-2.0.16, and the
"waagent -uninstall" will not recover that. So I suggest not to change
that while installing.

Version-Release number of selected component (if applicable):
WALinuxAgent-2.0.16-1.el6

How reproducible:
Always

Steps to Reproduce:
1. waagent -install -verbose
2. Check the /etc/ssh/sshd_config, "ClientAliveInterval" line.

Actual results:
The "ClientAliveInterval" is set to 180.

Expected results:
Don't change "ClientAliveInterval" line.

Additional info:
None.
Comment 4 yuxisun@redhat.com 2016-08-09 01:17:41 EDT
This feature doesn't exist in WALinuxAgent. Close this issue.
Comment 5 yuxisun@redhat.com 2016-08-09 04:50:43 EDT

*** This bug has been marked as a duplicate of bug 1360493 ***

Note You need to log in before you can comment on or make changes to this bug.