Bug 1311887 - /dev/disk/by-id/wwn-* links for SATA devices have words in reverse order
/dev/disk/by-id/wwn-* links for SATA devices have words in reverse order
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: systemd-maint
Frantisek Sumsal
: ZStream
Depends On: 1308795
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 04:43 EST by Jan Kurik
Modified: 2016-03-31 17:55 EDT (History)
11 users (show)

See Also:
Fixed In Version: systemd-219-19.el7_2.7
Doc Type: Bug Fix
Doc Text:
Due to an endianness problem, systemd previously read the device identification bytes in an incorrect order. As a consequence, the /dev/disk/by-id/wwn-* symbolic links generated by the udev device manager were incorrect. A patch has been applied to put the device identification bytes in the correct order. As a result, the mentioned symbolic links are generated correctly.
Story Points: ---
Clone Of: 1308795
Environment:
Last Closed: 2016-03-31 17:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-02-25 04:43:48 EST
This bug has been copied from bug #1308795 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 11 Frantisek Sumsal 2016-03-08 12:08:40 EST
1) Reproducer
## You need a machine with SATA HDD (/dev/sda in this case)
# export CURRENT_ID=$(udevadm info -p /sys/class/block/sda | grep "ID_WWN=" | sed -re 's/.*ID_WWN=0x(.+)/\1/')
# export EXPECTED_ID=$(hdparm -I /dev/sda | grep WWN | sed -re 's/.+ Identifier: (.+)/\1/')
# echo "Current ID: $CURRENT_ID | Expected ID: $EXPECTED_ID"
# [[ "$CURRENT_ID" == "$EXPECTED_ID" ]]
# echo $?

2) Output
a) Old package
# echo "Current ID: $CURRENT_ID | Expected ID: $EXPECTED_ID"
Current ID: 289d0c320751500a | Expected ID: 500a07510c32289d
# [[ "$CURRENT_ID" == "$EXPECTED_ID" ]]
# echo $?
1

b) New package
# echo "Current ID: $CURRENT_ID | Expected ID: $EXPECTED_ID"
Current ID: 500a07510c32289d | Expected ID: 500a07510c32289d
# [[ "$CURRENT_ID" == "$EXPECTED_ID" ]]
# echo $?
0
Comment 13 errata-xmlrpc 2016-03-31 17:55:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0181.html

Note You need to log in before you can comment on or make changes to this bug.