Bug 1311895 - Default mount point while creating brick from UI should be /rhgs/brick
Default mount point while creating brick from UI should be /rhgs/brick
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Sahina Bose
SATHEESARAN
: ZStream
Depends On:
Blocks: Gluster-HC-1 1328391
  Show dependency treegraph
 
Reported: 2016-02-25 04:51 EST by RamaKasturi
Modified: 2016-08-23 17:03 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1328391 (view as bug list)
Environment:
Last Closed: 2016-08-23 17:03:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55048 master ABANDONED engine: Update default gluster brick mount path 2016-04-05 10:59 EDT

  None (edit)
Description RamaKasturi 2016-02-25 04:51:24 EST
Description of problem:
when user tries to create a brick default mount point as of now in the UI is /gluster-bricks/brick where as it should be /rhgs/brick

Version-Release number of selected component (if applicable):
rhevm-3.6.3.3-0.1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Login to UI
2. Try creating a brick from UI
3. 

Actual results:
By default the mount point is chosen as /gluster-bricks/<brickname>

Expected results:
By default the mount point should be /rhgs/<brickname>

Additional info:
Comment 5 Mike McCune 2016-03-28 19:32:32 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Sahina Bose 2016-04-04 04:54:01 EDT
RHGS downstream documentation and tools continue to refer to mount point as /rhgs - hence need this downstream change to be consistent with these tools and documentation.

Retargeting to 3.6.6 as this is a minor change.
Comment 7 Sandro Bonazzola 2016-04-04 07:23:33 EDT
(In reply to Sahina Bose from comment #6)
> RHGS downstream documentation and tools continue to refer to mount point as
> /rhgs - hence need this downstream change to be consistent with these tools
> and documentation.
> 
> Retargeting to 3.6.6 as this is a minor change.

Sahina are you sure this should go to rhevm-setup-plugins and not to rhsc-setup-plugins?

Why is this becoming an issue in 3.6.6? 
Has documentation and tools changed since 3.5?

Why /rhgs is now required and it wasn't before?
Comment 8 Sahina Bose 2016-04-04 07:29:39 EDT
(In reply to Sandro Bonazzola from comment #7)
> (In reply to Sahina Bose from comment #6)
> > RHGS downstream documentation and tools continue to refer to mount point as
> > /rhgs - hence need this downstream change to be consistent with these tools
> > and documentation.
> > 
> > Retargeting to 3.6.6 as this is a minor change.
> 
> Sahina are you sure this should go to rhevm-setup-plugins and not to
> rhsc-setup-plugins?
> 
> Why is this becoming an issue in 3.6.6? 
> Has documentation and tools changed since 3.5?
> 
> Why /rhgs is now required and it wasn't before?

Yes, this is for rhevm-setup-plugins to change the downstream rhev behaviour. (rhsc has a separate d/s change)

It is targeted for 3.6.6 as we want HC setup to work with minimal user changes.
Brick provisioning was not available in 3.5
Comment 9 Sandro Bonazzola 2016-04-05 03:05:07 EDT
(In reply to Sahina Bose from comment #8)
> Yes, this is for rhevm-setup-plugins to change the downstream rhev
> behaviour. (rhsc has a separate d/s change)

I see https://gerrit.ovirt.org/#/c/55048/ is meant to fix the issue upstream, if so why do you need to change rhevm-setup-plugins?
Comment 10 Sahina Bose 2016-04-05 10:59:46 EDT
(In reply to Sandro Bonazzola from comment #9)
> (In reply to Sahina Bose from comment #8)
> > Yes, this is for rhevm-setup-plugins to change the downstream rhev
> > behaviour. (rhsc has a separate d/s change)
> 
> I see https://gerrit.ovirt.org/#/c/55048/ is meant to fix the issue
> upstream, if so why do you need to change rhevm-setup-plugins?

I submitted this upstream patch initially - but it wasn't the right approach as it's a downstream specific name. Hence the change to rhevm-setup-plugins and change of product in bz.
Abandoning the upstream patch in favour of rhevm-setup-plugin change
Comment 12 SATHEESARAN 2016-08-16 12:36:15 EDT
Tested with gluster 3.7.9 and RHV 4.0.2-6

The bricks are mounted at /rhgs/<given-brick-name>
Comment 14 errata-xmlrpc 2016-08-23 17:03:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1675.html

Note You need to log in before you can comment on or make changes to this bug.