Bug 131190 - pam_limits misses support for new limits in 2.6 kernel
pam_limits misses support for new limits in 2.6 kernel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-28 14:08 EDT by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 07:21:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adds sigpending and mqueue params to pam_limits (1.40 KB, patch)
2004-12-21 18:02 EST, toby cabot
no flags Details | Diff
adds sigpending and mqueue params to pam_limits (1.40 KB, patch)
2004-12-21 18:03 EST, toby cabot
no flags Details | Diff
Patch applied to upstream (2.15 KB, patch)
2005-01-07 07:25 EST, Tomas Mraz
no flags Details | Diff

  None (edit)
Description Ulrich Drepper 2004-08-28 14:08:29 EDT
Description of problem:
The 2.6 kernel supports two new limits, RLIMIT_SIGPENDING and
RLIMIT_MSGQUEUE.  Supporting them is potentially really important some
applications might not run with the default limits and on many-user
machines the defaults are likely too high.

Version-Release number of selected component (if applicable):
pam-0.77-54

How reproducible:
always

Steps to Reproduce:
1.well, read PAM docs and sources
2.
3.
  
Actual results:
Support not there

Expected results:
Support sigpending and mqueue limits

Additional info:
bash-3.0-8 has support for these limits so checking whether the code
works is easy.
Comment 1 toby cabot 2004-12-21 18:02:37 EST
Created attachment 108984 [details]
adds sigpending and mqueue params to pam_limits

hi, here's a patch that adds two parameters to pam_limits.c so you can set the
limits on pending signals and POSIX queue memory.  It applies against 0.77
(which is what my system is running) but looks like it should apply against
0.78 also.
Comment 2 toby cabot 2004-12-21 18:03:11 EST
Created attachment 108985 [details]
adds sigpending and mqueue params to pam_limits

hi, here's a patch that adds two parameters to pam_limits.c so you can set the
limits on pending signals and POSIX queue memory.  It applies against 0.77
(which is what my system is running) but looks like it should apply against
0.78 also.
Comment 3 Ulrich Drepper 2004-12-21 18:18:08 EST
Comment on attachment 108984 [details]
adds sigpending and mqueue params to pam_limits

one copy is enough
Comment 4 Ulrich Drepper 2004-12-21 18:25:18 EST
Comment on attachment 108984 [details]
adds sigpending and mqueue params to pam_limits

one copy is enough
Comment 5 Ulrich Drepper 2004-12-21 18:33:30 EST
The patch looks OK, although you might need #ifdefs the new code.

The problem is, though, that this is a change inthe configuration file format. 
I cannot speak for Tomas, but I wouldn't accept the patch unless it is blessed
by upstream.  Otherwise the upstream maintainer might use different keywords and
then the config files are incompatible.
Comment 6 Tomas Mraz 2004-12-25 14:52:52 EST
As I am one of the upstream maintainers, this shouldn't be a problem.
Comment 7 Tomas Mraz 2005-01-07 07:21:13 EST
OK, I've commited that to upstream CVS however I've actually decided to rename
the mqueue to msgqueue as all the other limits use the same name as in
RLIMIT_xxxx defines. And I added the #ifdefs.
Comment 8 Tomas Mraz 2005-01-07 07:25:10 EST
Created attachment 109462 [details]
Patch applied to upstream
Comment 9 toby cabot 2005-01-07 08:11:02 EST
thanks Tomas!

Note You need to log in before you can comment on or make changes to this bug.