Bug 1311905 - tomcat-8.0.32: tomcat version fails with load error org.apache.catalina.util.ServerInfo
tomcat-8.0.32: tomcat version fails with load error org.apache.catalina.util....
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tomcat (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Ivan Afonichev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 05:02 EST by Christian Heimes
Modified: 2016-03-25 18:22 EDT (History)
10 users (show)

See Also:
Fixed In Version: tomcat-8.0.32-5.fc23 tomcat-7.0.68-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 21:26:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1311771 None None None 2016-02-25 05:02 EST

  None (edit)
Description Christian Heimes 2016-02-25 05:02:20 EST
Description of problem:
The command 'tomcat version' fails on rawhide.

Version-Release number of selected component (if applicable):
tomcat-8.0.32-2.fc24

How reproducible:
Always

Steps to Reproduce:
1. install tomcat
2. run 'tomcat version'

Actual results:
Error: Could not find or load main class org.apache.catalina.util.ServerInfo

Expected results:
Tomcat's version information

Additional info:
It looks like tomcat can't load the class because CATALINA_HOME is not set. The issue is related to #1311771 and also blocks FreeIPA and Dogtag PKI.
Comment 1 Fedora Update System 2016-02-27 10:43:22 EST
tomcat-7.0.68-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b19c75d748
Comment 2 Fedora Update System 2016-02-27 10:43:23 EST
tomcat-8.0.32-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a266936df7
Comment 3 Fedora Update System 2016-02-28 08:50:53 EST
tomcat-7.0.68-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b19c75d748
Comment 4 Fedora Update System 2016-02-28 08:53:45 EST
tomcat-8.0.32-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a266936df7
Comment 5 Christian Heimes 2016-02-29 04:05:19 EST
With tomcat-8.0.32-4.fc23 and tomcat-7.0.68-2.fc22, Dogtag still fails to start with error message "Could not find or load main class org.apache.catalina.startup.Bootstrap".
Comment 6 Fedora Update System 2016-03-11 01:48:42 EST
tomcat-7.0.68-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6651efbaf
Comment 7 Fedora Update System 2016-03-11 01:49:45 EST
tomcat-8.0.32-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-48ee453d15
Comment 8 Fedora Update System 2016-03-12 11:53:07 EST
tomcat-7.0.68-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6651efbaf
Comment 9 Fedora Update System 2016-03-12 12:25:12 EST
tomcat-8.0.32-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-48ee453d15
Comment 10 Fedora Update System 2016-03-24 21:26:31 EDT
tomcat-8.0.32-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-03-25 18:21:15 EDT
tomcat-7.0.68-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.