Bug 1311907 - curl loops when storing cookies
curl loops when storing cookies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 05:02 EST by Jan Pazdziora
Modified: 2016-02-28 07:19 EST (History)
2 users (show)

See Also:
Fixed In Version: curl-7.43.0-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-28 07:19:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2016-02-25 05:02:55 EST
Description of problem:

I have tests that do

curl -b /tmp/headers.$$ -c /tmp/cookies.$$ -Lksi https://$( hostname )$LOGIN_URL

I see them fail due to curl going into 100% CPU infinite loop.

Version-Release number of selected component (if applicable):

curl-7.43.0-5.fc23.x86_64

How reproducible:

Deterministic but part of large test.

Steps to Reproduce:
1. Look at lib/cookie.c code, function cookie_output.

Actual results:

    while(co) {
      if(!co->domain)
        continue;

Expected results:

Something which has lower potential of going into infinite loop.

Additional info:

I believe ef0fdb83b89c87b63e94bf6ecdab5cd8c6458b2e addresses the problem. Please consider backporting it to Fedora 23.
Comment 1 Kamil Dudka 2016-02-25 05:25:29 EST
Thank you for reporting the bug!  I have included the upstream fix in f23:

http://pkgs.fedoraproject.org/cgit/rpms/curl.git/commit/?id=0c9fbb7e
Comment 2 Fedora Update System 2016-02-25 06:54:59 EST
curl-7.43.0-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c652a79610
Comment 3 Fedora Update System 2016-02-26 15:53:07 EST
curl-7.43.0-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c652a79610
Comment 4 Fedora Update System 2016-02-28 07:19:41 EST
curl-7.43.0-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.