Bug 1311910 (CVE-2016-2113) - CVE-2016-2113 samba: Server certificates not validated at client side
Summary: CVE-2016-2113 samba: Server certificates not validated at client side
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-2113
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20160412,repor...
Depends On: 1322688 1322689 1322690 1322691 1322692 1324807 1325382 1325383 1325384 1325385 1325645 1325649 1325650 1325651 1326453
Blocks: 1311915
TreeView+ depends on / blocked
 
Reported: 2016-02-25 10:08 UTC by Adam Mariš
Modified: 2019-06-08 21:01 UTC (History)
15 users (show)

Fixed In Version: samba 4.4.1, samba 4.3.7, samba 4.2.10
Doc Type: Bug Fix
Doc Text:
It was found that Samba did not validate SSL/TLS certificates in certain connections. A man-in-the-middle attacker could use this flaw to spoof a Samba server using a specially crafted SSL/TLS certificate.
Clone Of:
Environment:
Last Closed: 2016-04-19 05:28:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2016:0612 normal SHIPPED_LIVE Critical: samba and samba4 security, bug fix, and enhancement update 2016-04-13 05:06:20 UTC
Red Hat Product Errata RHSA-2016:0614 normal SHIPPED_LIVE Critical: samba security, bug fix, and enhancement update 2016-04-13 01:38:55 UTC
Red Hat Product Errata RHSA-2016:0618 normal SHIPPED_LIVE Critical: samba security, bug fix, and enhancement update 2016-04-13 05:25:52 UTC
Red Hat Product Errata RHSA-2016:0620 normal SHIPPED_LIVE Critical: samba4 security, bug fix, and enhancement update 2016-04-13 01:20:34 UTC

Description Adam Mariš 2016-02-25 10:08:15 UTC
It was found that while having a support for TLS/SSL for some protocols like ldap and http, certificates are not validated at all. When having a "tls cafile" option, configured certificate is not used to validate the server certificate.

Currently all Samba versions >= 4.0.0 are affected.

Upstream bug:

https://bugzilla.samba.org/show_bug.cgi?id=11752

Comment 5 Huzaifa S. Sidhpurwala 2016-04-11 05:37:21 UTC
Acknowledgements:

Name: the Samba project
Upstream: Stefan Metzmacher (SerNet)

Comment 6 Huzaifa S. Sidhpurwala 2016-04-11 05:45:14 UTC
External Reference:

https://access.redhat.com/articles/2243351

Comment 7 Huzaifa S. Sidhpurwala 2016-04-12 17:11:22 UTC
Public via:

https://www.samba.org/samba/security/CVE-2016-2113.html

Comment 8 Siddharth Sharma 2016-04-12 17:28:35 UTC
Created samba tracking bugs for this issue:

Affects: fedora-all [bug 1326453]

Comment 9 errata-xmlrpc 2016-04-12 21:24:44 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6.6 Extended Update Support
  Red Hat Enterprise Linux 6.5 Advanced Update Support
  Red Hat Enterprise Linux 6.4 Advanced Update Support
  Red Hat Enterprise Linux 6.2 Advanced Update Support

Via RHSA-2016:0620 https://rhn.redhat.com/errata/RHSA-2016-0620.html

Comment 10 errata-xmlrpc 2016-04-12 21:39:50 UTC
This issue has been addressed in the following products:

  Red Hat Gluster Storage 3.1 for RHEL 7
  Red Hat Gluster Storage 3.1 for RHEL 6

Via RHSA-2016:0614 https://rhn.redhat.com/errata/RHSA-2016-0614.html

Comment 11 errata-xmlrpc 2016-04-13 01:07:29 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7
  Red Hat Enterprise Linux 6

Via RHSA-2016:0612 https://rhn.redhat.com/errata/RHSA-2016-0612.html

Comment 12 errata-xmlrpc 2016-04-13 01:27:25 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7.1 Extended Update Support

Via RHSA-2016:0618 https://rhn.redhat.com/errata/RHSA-2016-0618.html

Comment 13 Fedora Update System 2016-04-13 20:21:33 UTC
samba-4.3.8-0.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-04-14 04:21:18 UTC
samba-4.2.11-0.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-04-15 03:17:04 UTC
samba-4.4.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.