Bug 1311921 - Incorrect indentation and value parameter in OSP 7.3 SSL documentation
Incorrect indentation and value parameter in OSP 7.3 SSL documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 05:43 EST by Guillaume Chenuet
Modified: 2016-03-15 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 23:32:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guillaume Chenuet 2016-02-25 05:43:09 EST
Description of problem:

When trying to apply the SSL part of OSP 7.3 doc, I found two mistakes:

1. Indentation of certificate (SSLCert, SSLKey, CACert) aren't correct.

Even with the 'IMPORTANT' note, examples aren't correct.
Certificate need one more tabulation.
Ex: 
parameter_defaults:
    SSLCertificate: |
    -----BEGIN CERTIFICATE-----

Correct way:
parameter_defaults:
    SSLCertificate: |
      -----BEGIN CERTIFICATE-----


2. In cloudname.yaml file, due to 'DnsServers' parameter, deployment will fail if the param is already set in templates.

If we use network-isolation functionalities, DnsServers are already set in network-environment.yaml file.

If you add this param in cloudname.yaml file, deployment with fail on Heat validation template with this kind of error, due of duplicate value:

Failed to validate: Failed to validate: Value must be valid JSON: Extra data: line 1 column 6 - line 1 column 13 (char 5 - 12)) _dispatch_and_reply /usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py:145

Should be good to add a warning/important note to ensure to have this value only one time.

Version-Release number of selected component (if applicable):

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Advanced-Scenario_3_Using_the_CLI_to_Create_an_Advanced_Overcloud_with_Ceph_Nodes.html#sect-Advanced-Enabling_SSL_TLS_on_the_Overcloud

How reproducible:

Trying to deploy SSL with an existing OSP templates (with network isolation)


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.