Bug 1311926 - [georep]: If a georep session is recreated the existing files which are deleted from slave doesn't get sync again from master
[georep]: If a georep session is recreated the existing files which are delet...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Milind Changire
:
Depends On: 1205162
Blocks: 1357772 1357773
  Show dependency treegraph
 
Reported: 2016-02-25 05:51 EST by Aravinda VK
Modified: 2017-03-27 14:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1205162
: 1357772 1357773 (view as bug list)
Environment:
Last Closed: 2017-03-27 14:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-02-25 05:51:27 EST
+++ This bug was initially created as a clone of Bug #1205162 +++

Description of problem:
=======================

If the files are deleted from slave volume after the session is deleted between master and slave volume. These files will never again sync after recreating the session. It is because we maintain the information in master for the files that are already sync.

Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.6.0.53-1.el6rhs.x86_64

How reproducible:
=================
1/1

Steps to Reproduce:
==================
1. Create and start a georep session between master and slave volume.
2. Create data to the master volume
3. Let the georep sync the data to the slave volume.
4. Once the data is synced to slave volume, stop and delete the session between master and slave.
5. Delete the files from slave volume
6. Re-create and start the session between master and slave volume.
7. The files that were deleted from slave volume doesn't get sync from master

--- Additional comment from Aravinda VK on 2015-12-08 04:27:51 EST ---

As part of geo-rep delete command, we should remove stime xattrs from Master Brick roots. So that on re-creation it will start syncing from beginning.
Comment 1 Vijay Bellur 2016-04-22 07:31:29 EDT
REVIEW: http://review.gluster.org/14051 (georep: [WIP] delete stime xattr on session delete) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2016-05-12 01:47:15 EDT
REVIEW: http://review.gluster.org/14051 (georep: delete stime xattr on session delete) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)
Comment 3 Vijay Bellur 2016-05-19 08:47:58 EDT
REVIEW: http://review.gluster.org/14051 (georep: reset stime xattr on session delete) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)
Comment 4 Vijay Bellur 2016-05-24 10:59:12 EDT
REVIEW: http://review.gluster.org/14051 (georep: reset stime xattr on session delete) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)
Comment 5 Vijay Bellur 2016-05-24 12:54:35 EDT
REVIEW: http://review.gluster.org/14051 (georep: reset stime xattr on session delete) posted (#5) for review on master by Milind Changire (mchangir@redhat.com)
Comment 6 Vijay Bellur 2016-05-27 02:58:20 EDT
REVIEW: http://review.gluster.org/14051 (georep: reset stime xattr on session delete) posted (#6) for review on master by Milind Changire (mchangir@redhat.com)
Comment 7 Vijay Bellur 2016-05-27 03:01:31 EDT
REVIEW: http://review.gluster.org/14051 (georep: reset stime xattr on session delete) posted (#7) for review on master by Milind Changire (mchangir@redhat.com)
Comment 8 Vijay Bellur 2016-05-27 03:22:08 EDT
REVIEW: http://review.gluster.org/14051 (georep: reset stime xattr on session delete) posted (#8) for review on master by Milind Changire (mchangir@redhat.com)
Comment 9 Vijay Bellur 2016-06-02 03:15:38 EDT
REVIEW: http://review.gluster.org/14051 (georep: add reset_sync_time option for session delete) posted (#9) for review on master by Milind Changire (mchangir@redhat.com)
Comment 10 Vijay Bellur 2016-06-02 07:46:01 EDT
REVIEW: http://review.gluster.org/14051 (georep: add reset-sync-time option for session delete) posted (#10) for review on master by Milind Changire (mchangir@redhat.com)
Comment 11 Vijay Bellur 2016-06-03 01:12:20 EDT
REVIEW: http://review.gluster.org/14051 (georep: add reset-sync-time option for session delete) posted (#11) for review on master by Milind Changire (mchangir@redhat.com)
Comment 12 Vijay Bellur 2016-06-03 05:05:43 EDT
REVIEW: http://review.gluster.org/14051 (georep: add reset-sync-time option for session delete) posted (#12) for review on master by Milind Changire (mchangir@redhat.com)
Comment 13 Vijay Bellur 2016-06-09 04:56:42 EDT
REVIEW: http://review.gluster.org/14051 (georep: add reset-sync-time option for session delete) posted (#13) for review on master by Milind Changire (mchangir@redhat.com)
Comment 14 Vijay Bellur 2016-06-27 07:05:06 EDT
REVIEW: http://review.gluster.org/14051 (georep: add reset-sync-time option for session delete) posted (#14) for review on master by Milind Changire (mchangir@redhat.com)
Comment 15 Vijay Bellur 2016-06-29 02:41:58 EDT
COMMIT: http://review.gluster.org/14051 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 70fd68d94f768c098b3178c151fa92c5079a8cfd
Author: Milind Changire <mchangir@redhat.com>
Date:   Fri Apr 22 16:56:47 2016 +0530

    georep: add reset-sync-time option for session delete
    
    Set the stime xattr at all the brick roots to (0,0) if the argument
    reset-sync-time has been provided on the command-line.
    To avoid testing against directory specific stime, the remote
    stime is assumed to be minus_infinity, if the root directory
    stime is set to (0,0), before the directory scan begins.
    This triggers a full volume resync to slave in the case of a
    geo-rep session recreation with the same master-slave volume
    pair.
    
    Command synopsis:
    gluster volume geo-replication <MASTERVOL> <SLAVE>::<SLAVEVOL> delete \
        [reset-sync-time]
    
    Update gluster cli man page to include new sub-command reset-sync-time.
    
    Change-Id: Ie4ce03b9425ed9bb81eda8681058c0fc6f990948
    BUG: 1311926
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/14051
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 16 Shyamsundar 2017-03-27 14:15:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.