Bug 131193 - Network interfaces init occure before PCMCIA init
Network interfaces init occure before PCMCIA init
Status: CLOSED DUPLICATE of bug 125250
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-28 14:50 EDT by Nikolay
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolay 2004-08-28 14:50:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.50  [bg]

Description of problem:
Initialization of the PCMCIA boards occure after the bringing up of 
the network interfaces. 
This cause the failing of bringing up the network if the netboard is 
pcmcia.
I my case, my wireless card is PCMCIA and it is not active in the 
begining and my interface eth1 (my wireless) not getting up.

Work around is to change the name of the init script of the PCMCIA in 
the rc5.d from S24 to S9 (network init is S10). Then network works 
fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.plug PCMCIA board and setup wireless interface to be activated at 
the boot
2.Restart machine
3.see the init of the network interface fail, notice the PCMCIA board 
is not active during network init
4. PCMCIA getting active (as S24) 
5. You manually should activate your interface
    

Actual Results:  bringing of the net interface of PCMCIA board fail, 
because PCMCIA board is not active at the time of init.

Expected Results:  Interface should be up 

Additional info:

Work around is to change the name of the init script of the PCMCIA in 
the rc5.d from S24 to S9 (network init is S10). Then network works 
fine.
Comment 1 Bill Nottingham 2004-09-08 02:48:57 EDT

*** This bug has been marked as a duplicate of 125250 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.