Bug 1311962 - virt-who complains "ERROR: Unable to send data: Unable to send host/guest assocaition to the satellite"
virt-who complains "ERROR: Unable to send data: Unable to send host/guest ass...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Chris Snyder
Eko
:
: 1325948 (view as bug list)
Depends On:
Blocks: 1355878
  Show dependency treegraph
 
Reported: 2016-02-25 07:18 EST by Jan Hutař
Modified: 2017-03-21 06:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: virt-who-0.18-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 06:28:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2016-02-25 07:18:05 EST
Description of problem:
virt-who errors out when you delete profiles it reported from Satellite 5.


Version-Release number of selected component (if applicable):
virt-who-0.12-10.el6.noarch


How reproducible:
always


Steps to Reproduce:
1. # rm -rf /var/lib/virt-who/*
2. # virt-who --one-shot --satellite5 --esx --satellite-server=<sat5>
     --satellite-username=<satuser> --satellite-password=<satpass>
     --esx-server=<vCenter> --esx-username=<esxuser> --esx-password=<esxpass>
3. Now delete profiles it has created on Sat5
4. # virt-who --one-shot --satellite5 --esx --satellite-server=<sat5>
     --satellite-username=<satuser> --satellite-password=<satpass>
     --esx-server=<vCenter> --esx-username=<esxuser> --esx-password=<esxpass>


Actual results:
2016-02-25 12:20:32,161 INFO: Using configuration "env/cmdline" ("esx" mode)
2016-02-25 12:20:43,125 INFO: Initialized satellite connection
2016-02-25 12:20:43,126 INFO: Sending update in hosts-to-guests mapping: {[...]}
2016-02-25 12:20:43,893 ERROR: Unable to send data: Unable to send host/guest assocaition to the satellite: <Fault -9: '\nError Message:\n    Please run rhn_register as root on this client\nError Class Code: 9\nError Class Info: Invalid System Credentials.\nExplanation: \n     An error has occurred while processing your request. If this problem\n     persists please consult the Red Hat Customer Portal Knowledge Base\n     landing page on common registration Error Class Codes at\n     https://access.redhat.com/solutions/17036 for a possible resolution.\n     If you choose to open a support case in the Red Hat Customer Portal,\n     please be sure to include details of what you were trying to do when\n     this error occurred and specifics on how to reproduce this problem.\n'>


Expected results:
Should work.


Additional info:
When you `rm -rf /var/lib/virt-who/*`, it works again.

When on this, there is also small typo in the error message above: assocaition -> association.

This was spotted when working on bug 1268799.
Comment 3 Radek Novacek 2016-05-03 11:40:43 EDT
The problem has been addressed upstream:

https://github.com/virt-who/virt-who/commit/94a35ea6e269faa3841de843928450287650c2cb
Comment 4 Radek Novacek 2016-05-05 02:50:57 EDT
*** Bug 1325948 has been marked as a duplicate of this bug. ***
Comment 5 Radek Novacek 2016-10-11 10:01:49 EDT
Fixed in virt-who-0.18-1.el6.
Comment 7 yuefliu 2017-02-08 03:22:13 EST
Verified the bug on virt-who-0.18-3.el6.noarch with satellite5.7, do as the bug's steps, host/guest mapping info can be sent to sat server successfully after delete profiles by run 'rm -rf /var/lib/virt-who/*', no such bug reproduce, so verified it.
Comment 9 errata-xmlrpc 2017-03-21 06:28:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0675.html

Note You need to log in before you can comment on or make changes to this bug.